Project

General

Profile

Actions

Bug #104133

open

SelectCheckBoxElement is broken as data-multi-record-selection must trigger data-is-dirty on checkbox-change

Added by Ayke Halder about 1 month ago. Updated 29 days ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2024-06-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
13
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The data-multi-record-selection JS-implementation looks like it was intended to be used for temporary selection of records in the TYPO3 backend - e.g. content-element-records selected in a list-view for 'copy to clipboard'-feature.

By sprint in https://forge.typo3.org/issues/104012 data-multi-record-selection became the new UI for SelectCheckBoxElement.
But data-multi-record-selection currently does not handle the neccessary features for multi-select-checkboxes which are stored in a database-field.

Especially checkbox-state changes triggered by click on background behind checkbox or toggle-menu must have the following features implemented:

  • Trigger data-is-dirty on checkbox change to make a dialogue 'Do you want to close without saving?' appear.
  • Respect disabled checkboxes and don't change their state.

Files


Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Task #104012: Unify toggle link occurrences: Use data-multi-record-selection in "Access Rights" of backend user and backend usergroupsClosed2024-06-10

Actions
Related to TYPO3 Core - Feature #103521: Merge tables_select and tables_modify views in Backend Group formClosedMarcin Sągol2024-04-02

Actions
Related to TYPO3 Core - Bug #104142: Disabled checkbox state can be changed via multi record selectionClosedOliver Bartsch2024-06-18

Actions
Actions #1

Updated by Ayke Halder about 1 month ago

  • Description updated (diff)
Actions #2

Updated by Ayke Halder about 1 month ago

  • Related to Task #104012: Unify toggle link occurrences: Use data-multi-record-selection in "Access Rights" of backend user and backend usergroups added
Actions #3

Updated by Ayke Halder about 1 month ago

  • Related to Feature #103521: Merge tables_select and tables_modify views in Backend Group form added

Updated by Ayke Halder about 1 month ago

Data-is-dirty on checkbox change

Click directly on the checkboxes:

Makes a dialogue 'Do you want to close without saving?' appear on switching away.

Click on background:

There is no dialogue 'Do you want to close without saving?' on switching away.

Actions #5

Updated by Riccardo De Contardi 29 days ago

  • Related to Bug #104142: Disabled checkbox state can be changed via multi record selection added
Actions #6

Updated by Riccardo De Contardi 29 days ago

  • Status changed from New to Closed

I close this issue as a duplicate of #104142 which has a patch attached. Please continue the discussion there

If you think that this is the wrong decision please reopen it or open a new issue with a reference to this one. Thank you.

Actions #7

Updated by Ayke Halder 29 days ago

  • Subject changed from SelectCheckBoxElement is broken as data-multi-record-selection needs implementation for disabled checkboxes and must trigger data-is-dirty on checkbox-change to SelectCheckBoxElement is broken as data-multi-record-selection must trigger data-is-dirty on checkbox-change

This one was solved: data-multi-record-selection needs implementation for disabled checkboxes

This one is still open: data-multi-record-selection must trigger Data-is-dirty on checkbox change

Actions #8

Updated by Riccardo De Contardi 29 days ago

  • Status changed from Closed to New

Reopened on request of the reporter. Sorry for the inconvenience

Actions

Also available in: Atom PDF