Bug #14694

Help->About module broken

Added by Ingmar Schlecht about 16 years ago. Updated over 14 years ago.

Status:
Closed
Priority:
Must have
Category:
-
Target version:
-
Start date:
2005-04-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
3.8.0rc1
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The Help->About module is broken.

This is the string it shows:

"TYPO3 is a flexible and professional Open Source Web-CMS based on PHP4 and MySQL.br /br /TYPO3 is bfreely available/b under the a href=http://typo3.com/1244.0.html target=_blankTYPO3-license (GNU/GPL)/a.br /br /TYPO3 Ver. 3.8.0beta2.1, Copyright © 1998-2005 Kasper Skårhøjbr /"

It seems like the string is passed thru htmlspecialchars() but shouldn't.

Would be cool if one of the bug fixers could care about this.

The file in question is probably typo3/mod/help/about/index.php
(issue imported from #M1009)

#1

Updated by Sebastian Kurfuerst about 16 years ago

appearently there was no change on this file and the problem exists in both beta versions. have to check this.

#2

Updated by Sebastian Kurfuerst almost 16 years ago

just rechecked it, cannot reproduce this anymore... Ingmar, it first occured in your install, is it still there?

#3

Updated by Ingmar Schlecht almost 16 years ago

For your information:

On the system I'm encountering the problem with, I detected the following misbehaviour of the function pair xml2array() and array2xml():

debug(t3lib_div::xml2array(t3lib_div::array2xml(array('this is <B>big</B>'))));
...results in "this is Bbig/B" instead of "this is <B>big</B>" which it should have been.

The problem can be tracked down to somewhere in t3lib_div::xml2array(). The function does not seem to care about entities (i.e. it strips out all entities).

The server is a WAMP system using latest apachefriends.org XAMPP package with PHP5.

I consider an error inside of xml2array() as a major bug, because it affects all entities in all XML locallang files in TYPO3 as well as entities in Flexform data and datastructures.

I'm sorry I was not yet able to fix the bug - and might not be able to do so before scheduled release of 3.8.0.

Anybody could reproduce this with the XAMPP package mentioned above.

#4

Updated by Pieter almost 16 years ago

I'm running WinXP Pro, ApacheFriends XAMPP (basic package) version 1.4.13 with:
+ Apache 2.0.53
+ MySQL 4.1.11
+ PHP 5.0.4 + PHP 4.3.11 + PEAR
+ eAccelerator 0.9.2a
+ PHP-Switch win32 1.0 (von Apachefriends, man nehme die "php-switch.bat")

Typo3 3.8RC1 Help->About is looking fine, both with PHP5 and PHP4.

#5

Updated by Ingmar Schlecht almost 16 years ago

Thanks, Pieterv, for testing this!

You are indeed right, it works with PHP 5.0.4.

The PHP5 ChangeLog http://www.php.net/ChangeLog-5.php mentions, that the bug ("XML Parser Functions seem to drop & when parsing") is fixed in PHP 5.0.4.

More info about the PHP bug: http://bugs.php.net/bug.php?id=31139

Also available in: Atom PDF