Bug #14959

Meta tag output in indexed search result breaks layout

Added by Nick Weisser almost 17 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Category:
Indexed Search
Target version:
-
Start date:
2005-09-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you have a list like so:

Gebäudeautomation, Gebäudetechnik, Telekommunikation, Netzwerkinstallation, Elektroinstallation, EIB/KNX Produkte

(note the space after the commas!)

in the page header's keywords field, the indexed search result page does not reenter the spaces and makes the comma seperated list look like so:

Gebäudeautomation,Gebäudetechnik,Telekommunikation,Netzwerkinstallation,Elektroinstallation,EIB/KNX Produkte

Problem: If you have a narrow content column this will break the layout and makes it much wider as desired.

(issue imported from #M1436)


Files

indexed-search-problem.png (94.5 KB) indexed-search-problem.png Administrator Admin, 2009-11-10 18:20
indexed-search-problem2.png (41.6 KB) indexed-search-problem2.png Administrator Admin, 2009-11-10 18:23
1436.diff (1.43 KB) 1436.diff Administrator Admin, 2010-03-23 16:46
#1

Updated by Nabil Saleh about 13 years ago

1st.
"in the page header's keywords field"
how can something in the headers keywords field influence a "a narrow content column"

If you mean the searchhistory under the search field:
I can't reproduce this with actual trunk

#2

Updated by Chris topher about 13 years ago

I think he means the search-results, where you get a bunch of information for each hit.

Are the values, which you have entered in the keywords-field for that page, still shown there without whitespaces?

#3

Updated by Karl Schlicker over 12 years ago

I've two images to show the problem.
Image indexed_search_problem2.png show the site 'home' in the backend with the keyword seperated by commas and whitespaces in front of the words.

Image indexed_search_problem.png show the result of a simple indexed search. The red market rows is the keyword line from the page, but now the keywords comma seperated without whitespaces in front of the words. The result is an broken layout, because the line with the keywords can do a line break.

I hope, this makes the problem clearer.

Best regards

BTW: TYPO3 Vers. 4.2.10, indexed_search 2.11.1

#4

Updated by Dmitry Dulepov over 12 years ago

Content comes from the index_fulltext table. The problem happens only and only if keywords meta does not have spaces in it. It works correctly if there are spaces.

The solution is to force spaces to keywords. There is no better way because the content is taken by the FE plugin from the index_fulltext, which is just a concatened list of strings.

#5

Updated by Dmitry Dulepov over 12 years ago

rev 7215, 7216

#6

Updated by Benni Mack almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF