Bug #15452

When moving records the translation do not move with it

Added by Aulis Telle over 13 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
-- undefined --
Category:
-
Target version:
-
Start date:
2006-01-19
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When I move a record with translations the translations do not move with it.
I localized that the move takes place in class.t3lib_tcemain.php->moveRecord but I am not enough into the typo3 core sources that I can fix that.

(issue imported from #M2314)

T3X_klee_translation-0_1_2-z-200812051716.t3x (6.46 KB) Administrator Admin, 2009-03-11 15:52

T3X_klee_tv_move_patch-0_1_0-z-200812051717.t3x (2.63 KB) Administrator Admin, 2009-03-11 15:52

before.gif View (16.9 KB) Administrator Admin, 2009-03-13 11:53

after.gif View (23.9 KB) Administrator Admin, 2009-03-13 11:53

0002314.patch View (2.74 KB) Administrator Admin, 2009-07-18 21:07

0002314_v2.patch View (3.95 KB) Administrator Admin, 2009-07-31 10:19

0002314_v3.patch View (4.37 KB) Administrator Admin, 2009-10-19 16:08

0002314_v5.patch View (6.79 KB) Administrator Admin, 2009-10-20 21:55


Related issues

Related to TYPO3 Core - Bug #14408: lang-children "get lost"(should be deleted) when deleting parent-record in default language Closed 2004-11-24
Related to TYPO3 Core - Bug #19014: Copying Content Elements does not copy Language Overlays Closed 2008-06-25
Related to TYPO3 Core - Bug #21301: List module renders wrong data in localization view when record-overlay was moved in WS Closed 2009-10-19
Related to TYPO3 Core - Bug #21304: List module and Clickmenu should not enable to create inconsistant record-relations Closed 2009-10-19
Related to TYPO3 Core - Bug #21500: Cannot move multiple records with clipboard Closed 2009-11-09

History

#1 Updated by Aulis Telle over 13 years ago

To make things easyer, one could set the sorting value of the translated elements always to the same value as the corresponding default language element.

#2 Updated by Sebastian Kurfuerst over 13 years ago

Hi,
I don't think the sorting field is good for this or needed.

Anyways, a solution is needed, of course - but I am not sure if this will make it into 4.0.
Greets, Sebastian

#3 Updated by Kasper Skaarhoj over 13 years ago

It will not make it for 4.0, but I confirm the issue. Its not a mistake, we just didn't find time to implement this.

#4 Updated by Philippe MIGUEL over 10 years ago

attached an extension (tested on version 4.1.5) + TV patch (tested with TV version 1.3.1) that fixes the cut/paste and copy/paste of contents with translations.

#5 Updated by Christian Toffolo over 10 years ago

Related to http://bugs.typo3.org/view.php?id=10552

I tested Philippe's extenstions in two of my installations:
TYPO3 4.1.7 / TV 1.3.4 global
TYPO3 4.2.10 / TV 1.3.7 local

I tested: copy; move; reference>create local copy
all those actions now preserve the localizations.

GJ Philippe, thank you!
ian

#6 Updated by Andreas Allenberg over 10 years ago

Typo3 4.2.6 / no TV

I only install the translation extension and copy a localized content element. The content elements are copied both twice. See screenshots ...

#7 Updated by Steffen Kamper over 10 years ago

looks good. Now we need core patch (i will take care for TV)

#8 Updated by Tolleiv Nietsch about 10 years ago

0002314_v2.patch should resolve the problems...

0002314.patch had issues since the placeholder-records for moved localizations weren't localized themselfes (which cause some renderings-issues within the list-module)

#9 Updated by Nils Winkler about 10 years ago

Hi,

I tested the patch / extension (0002314_v2.patch and T3X_klee_translation-0_1_2-z-200812051716.t3x) with TYPO3 4.2.9 and it works.

The extension T3X_klee_tv_move_patch-0_1_0-z-200812051717.t3x seems not to be necessary. If you also use this extension, the main element will be copied twice.

Without T3X_klee_translation-0_1_2-z-200812051716.t3x the translated element will not be copied.

Regards, Nils.

#10 Updated by Markus Timtner about 10 years ago

Hi there!

I witnessed some strange behavior of the extension:
(might be relevant to the patch, too)

When copying elements within "web->list" module, everything works as expected.

But when copying elements in "web->page" module, the copied elements have lost their translation relations and localisation settings, they all appear in the default language column now.

Kind regards, markus

#11 Updated by Nils Winkler about 10 years ago

@Markus: which files do you have installed? Just the extension or also a patch?

#12 Updated by Markus Timtner about 10 years ago

@nils: Just the extension: T3X_klee_translation-0_1_2-z-200812051716.t3x

#13 Updated by Nils Winkler about 10 years ago

@Markus: I needed also the 0002314_v2.patch like I've written a few notes above.

#14 Updated by Markus Timtner about 10 years ago

OK, that might cause the problem...
the issue is with a TYPO3 v4.1.7 here.

#15 Updated by Markus Timtner about 10 years ago

Hi there again.

I still encounter that weird behavior that copied content elements with translations somehow loose their relations...

Tested in TYPO3 v4.1.7 and v4.2.9, patch 2314_v2 and T3X_klee_translation-0_1_2-z-200812051716.t3x installed.

Here are the steps for reproduction:
1. apply patch 2314_v2
2. install T3X_klee_translation-0_1_2-z-200812051716.t3x
3. create test content with translations
4. now "web->page" copy only the element of the default language
and then "paste after"
Result: all elements get copied, but loose their relations.

The only way which succeeds in copying an element invcluding relations is within list module, table "page content" and then insertion via the table "head".

Ok, but when this new content element has to be moved somehow, it will still loose all its relations, eventually.

#16 Updated by Nils Winkler about 10 years ago

@Markus: is you destination page available in all languages?
Do you use TemplaVoila or traditional pages?

I use TV.

#17 Updated by Markus Timtner about 10 years ago

@Nils: I copy the elements on the same page - didn't tried to copy to other pages yet. No, I do not use TemplaVoila.

#18 Updated by Tolleiv Nietsch about 10 years ago

I've just sent a patch to the dev-list (it resolved a couple of related issues as well) - I'd be glad to get some feedback

#19 Updated by Nils Winkler about 10 years ago

@Tolleiv: could you please write which files are needed for TYPO3 with TemplaVoila and which for a plain TYPO3 installation?

#20 Updated by Tolleiv Nietsch about 10 years ago

@Nils - this is no TemplaVoila issue - TemplaVoila just uses the t3lib_tcemain to perform copy/move/delete actions - please check the typo3.dev list and you'll find the Core-patch file - I didn't attach it to this issue because at the moment it resolves a couple of related issues at once (it not "Core-list ready" yet)

#21 Updated by Tolleiv Nietsch almost 10 years ago

attached patch 0002314_v3.patch depends on changes from #14408- besides no other changes needed...

#22 Updated by Rupert Germann almost 10 years ago

FYI: committed to trunk rev 6193

Also available in: Atom PDF