Project

General

Profile

Actions

Bug #15604

closed

versioning a page breaks all MM-Relations

Added by old_pekue over 18 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Must have
Category:
Workspaces
Target version:
-
Start date:
2006-02-10
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.0
PHP Version:
4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

on versioning of a page all records that are copied along with it (configured as 'versioning_followPages') loose their mm-relations

i added two lines to copyRecord_raw() that seem to solve the issue (see att. xclass)
(issue imported from #M2531)


Files

class.ux_ux_t3lib_tcemain.php (10.6 KB) class.ux_ux_t3lib_tcemain.php Administrator Admin, 2006-02-10 13:16
class.ux_ux_t3lib_tcemain.php.correct (10.5 KB) class.ux_ux_t3lib_tcemain.php.correct Administrator Admin, 2006-02-10 13:54
Actions #1

Updated by old_pekue over 18 years ago

unset($this->dbAnalysisStore);

doesnt work since dbAnalysisStoreExec() doesnt check if $this->dbAnalysisStore is an array

changed to:
$this->dbAnalysisStore=array();

see class.ux_ux_t3lib_tcemain.php.correct
thnx

Actions #2

Updated by Michael Stucki over 18 years ago

It seems this problem is still not fixed.

Actions #3

Updated by Michael Stucki over 18 years ago

Peter, can you please confirm if this is still open?

Actions #4

Updated by Ingmar Schlecht over 18 years ago

Kasper, is this bug already fixed?

If not, is it something we should wait for, before releasing 4.0?

Actions #5

Updated by Ingo Renner almost 16 years ago

Is this still valid with 4.2? I remember Kasper made some changes to workspace versioning and MM handling...

Actions #6

Updated by Ingmar Schlecht almost 16 years ago

i'm pretty sure this is fixed with kasper's patch from december 2007. Didn't test it though.

Cheers,
ingmar

Actions #7

Updated by Herbert Sojnik over 14 years ago

Kasper made a few changes in the previous versions, so in most cases everything works fine in latest version 4.2.11.

We found out, that there remains at least one case, where the mm relations are still broken (deleted). This is the case, if the fields are displayed as checkboxes in backend ("renderMode" => "checkbox")

We made following small patch in class.t3lib_tcemain.php an now everything works fine in our installation:

function getVersionizedIncomingFieldArray ( .. ) {
...
$newValueArray = array();

// patched by abaton
if (is_array($value)) $value = implode(',', $value);

$origValueArray = explode(',', $value);
...
}

-> please correct me, if my note/solution is completely wrong here.

Actions #8

Updated by Benni Mack over 13 years ago

I closed this one as we won't support page versioning anymore anyways since TYPO3 4.4.

Actions #9

Updated by Michael Stucki over 10 years ago

  • Category changed from Miscellaneous to Workspaces
Actions #10

Updated by Michael Stucki over 10 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
  • Target version deleted (0)
Actions

Also available in: Atom PDF