Bug #15700

Wrong hardcoded path to fileicons in class.tslib_content.php

Added by Franz Koch almost 14 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
Should have
Category:
Communication
Target version:
-
Start date:
2006-02-22
Due date:
% Done:

0%

TYPO3 Version:
4.0
PHP Version:
5
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I just tested 4.0 beta3 and noticed that the fileicons where missing in the content-elements "uploads". The hardcoded path in "sysext/cms/tslib/class.tslib_content.php" on line 3843 is wrong.

Wrong:
$iconP = t3lib_extMgm::siteRelPath('cms').'media/fileicons/';

Correct:
$iconP = t3lib_extMgm::siteRelPath('cms').'tslib/media/fileicons/';

At least works for me on windows, zip-package. Couldn't check the linux-package, but as it should be the same now (no symlinks) the bug should be there, too.

but as this should become customizable anyway, maybe this bug will become obsolete

featurerequest for customizable icon-path see bug 1378:
http://bugs.typo3.org/view.php?id=1378

(issue imported from #M2667)


Related issues

Related to TYPO3 Core - Bug #14927: Fileicon-Path is hardcoded and not changeable for the Frontend Closed 2005-08-16
Related to TYPO3 Core - Bug #22402: Wrong path to fileicons and only default logo in filelinks Closed 2010-04-09
Duplicated by TYPO3 Core - Bug #15745: Wrong path to fileicons and only default logo in filelinks Closed 2006-02-28

History

#1 Updated by Michael Stucki almost 14 years ago

I think this was fixed, isn't it?

#2 Updated by Karsten Dambekalns almost 14 years ago

The code is like suggested, so it should work.

Also available in: Atom PDF