Gremlin: The running TYPO3 version (4.0-CVS) is higher than allowed (0.0.2)
When installing an extension which has weird version numbers in its constraints due to the switch to TER2, the users gets a warning which is technically correct but annoying.
Install an extension which depends on TYPO3 version 0.0.2 or similar
Just ignore every constraint with TYPO3 version < 3.x.x and PHP version 3.0.0
(issue imported from #M3039)
#4 Updated by Ingmar Schlecht about 13 years ago
So is the fix already in CVS or listed on http://typo3.org/development/40rc2-to-rc3-patches/?
#6 Updated by Karsten Dambekalns about 13 years ago
News on this one: it still fails with rlmp_eventdb, because it has this in it's constraints:
'typo3' => '3.7.2-0.0.2',
'php' => '4.3.2-0.0.2',
But, since constraints didn't exist with the old EM, this get's initialized from PHP_version or TYPO3_version only if it's not already present in the constraints. And only during initializing the range is checked for sensible values.
I'd consider this a bug in your extension and would not add a check. Or would it be better to always check this and free extension authors from being responsible for the constraints they define (no pun intended!)?