Bug #15936

Gremlin: The running TYPO3 version (4.0-CVS) is higher than allowed (0.0.2)

Added by Robert Lemke over 13 years ago. Updated about 13 years ago.

Status:
Closed
Priority:
Must have
Category:
Extension Manager
Target version:
-
Start date:
2006-03-29
Due date:
% Done:

0%

TYPO3 Version:
4.0
PHP Version:
5
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When installing an extension which has weird version numbers in its constraints due to the switch to TER2, the users gets a warning which is technically correct but annoying.

Install an extension which depends on TYPO3 version 0.0.2 or similar

Just ignore every constraint with TYPO3 version < 3.x.x and PHP version 3.0.0
(issue imported from #M3039)

em-versionhigherthanallowed.png View (7.92 KB) Administrator Admin, 2006-03-29 09:50


Related issues

Related to TYPO3 Core - Bug #15930: Importing/installing skin_grey_2 in 4.0 RC2 reports Invalid argument supplied for foreach() .. class.em_index.php Closed 2006-03-28
Related to TYPO3 Core - Bug #15877: EM doesn't respect dependencies if no version number is specified Closed 2006-03-22

History

#1 Updated by Karsten Dambekalns over 13 years ago

Hm, it should ignore those already (or rather, fix them to theminimum values we talked about)... I'll have a look.

#2 Updated by Ingmar Schlecht over 13 years ago

I can confirm that those weird version numbers are not ignored.

#3 Updated by Karsten Dambekalns over 13 years ago

Works as expected after fixing #15930, so probably the check/fix was skipped because the (broken) constraints were already present.

#4 Updated by Ingmar Schlecht over 13 years ago

So is the fix already in CVS or listed on http://typo3.org/development/40rc2-to-rc3-patches/?

cheers,
ingmar

#5 Updated by Karsten Dambekalns over 13 years ago

@Ingmar: no, no. I just sent an email to the core-list.

#6 Updated by Karsten Dambekalns over 13 years ago

News on this one: it still fails with rlmp_eventdb, because it has this in it's constraints:
'typo3' => '3.7.2-0.0.2',
'php' => '4.3.2-0.0.2',

But, since constraints didn't exist with the old EM, this get's initialized from PHP_version or TYPO3_version only if it's not already present in the constraints. And only during initializing the range is checked for sensible values.

I'd consider this a bug in your extension and would not add a check. Or would it be better to always check this and free extension authors from being responsible for the constraints they define (no pun intended!)?

Also available in: Atom PDF