Bug #15877

EM doesn't respect dependencies if no version number is specified

Added by Robert Lemke over 13 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Extension Manager
Target version:
-
Start date:
2006-03-22
Due date:
% Done:

0%

TYPO3 Version:
4.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After downloading an extension which depends on other extension but not on specific versions of them, these dependencies don't appear in the EM locally and are not checked either.
However, these constraints are displayed correctly at TYPO3.org

Download rlmp_eventdb 1.0.4 with EM2 from TER2. View details in the EM: No dependencies are shown.

Constraints of rlmp_eventdb:

'depends' => array(
'php' => '4.3.1-',
'typo3' => '3.7.1-',
'cms' => '',
'lang' => '',
'address' => '',
'moneylib' => '',
'rlmp_dateselectlib' => '',
'overlib' => '',
'frontendformslib' => '',
),

(issue imported from #M2954)


Related issues

Related to TYPO3 Core - Bug #15936: Gremlin: The running TYPO3 version (4.0-CVS) is higher than allowed (0.0.2) Closed 2006-03-29
Related to TYPO3 Core - Bug #15948: Installation blocks complete BE Closed 2006-03-29

History

#1 Updated by Karsten Dambekalns over 13 years ago

It does respect them if I try to install the extension, at least...

#2 Updated by Karsten Dambekalns over 13 years ago

It shows them in the extension's detail view, too.

#3 Updated by Karsten Dambekalns over 13 years ago

Seems fixed for me, can you double-check? Thanks.

#4 Updated by Karsten Dambekalns over 13 years ago

Any new results?

#5 Updated by Karsten Dambekalns over 13 years ago

News: empty version dependencies work, but for some reason the constraints of the ext in TER do not list moneylib as shown above. Is the above code from your local dev version?

#6 Updated by Marcus Krause almost 11 years ago

What's the current status?

#7 Updated by Steffen Kamper almost 11 years ago

i think the problem is partly solved in new versions.
Anyway there are some issues left which has to be mentioned here.

#8 Updated by Helmut Hummel about 8 years ago

  • Status changed from Accepted to Needs Feedback
  • Target version deleted (0)
  • PHP Version deleted (5)

Still a problem? I cannot reproduce with current versions.

#9 Updated by Alexander Opitz over 6 years ago

  • Status changed from Needs Feedback to Closed

No response over one year => closed.

Also available in: Atom PDF