Bug #16491

CSV-Download of records impossible in HTTPS-Backend and Internet Explorer

Added by old_root old_root almost 16 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2006-08-25
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When trying to download a CSV-file of records in the backend IE throws an error message (file could not be transferres...page could not be found) and no file is being downloaded. This only occurs in a completely HTTPS-secured backend.
This seems to be a more general problem as some extensions are sporting the same behaviour (questionaire-export etc.). Most certainly an IE-bug, but it HAS to work anyways.

(issue imported from #M4097)


Files

csv_fix.diff (799 Bytes) csv_fix.diff Administrator Admin, 2010-07-15 12:52
#1

Updated by Andrew Henson almost 12 years ago

This issue is still live in the latest version of TYPO3. It affects IE 6, 7 and 8. I have attached a patch which resolves it. I have tested it with IE8 in a HTTPS secured backend.

Similar issues may lie elsewhere in TYPO3 where downloads are taking place.

#2

Updated by Chris topher almost 12 years ago

Hi Andrew,

thanks for your feedback and for the patch!

Please send it to Core List to get it integrated in the next releases.
Check out http://typo3.org/teams/core/core-mailinglist-rules

PS: Please use tabs to indent the lines.

#3

Updated by Alexander Opitz about 9 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#4

Updated by Gerrit Code Review about 9 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20902

#6

Updated by Gerrit Code Review about 9 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20902

#7

Updated by Gerrit Code Review about 9 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20902

#8

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27476

#9

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_6-0 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27477

#10

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27480

#11

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27481

#12

Updated by Christian Kuhn over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#13

Updated by Benni Mack almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF