Bug #16983

Secure File downloads with jumpurl.secure = 1 not working in TV

Added by Lukas Rüegg almost 14 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2007-02-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.1
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Using the following code in a TV DS will always get an error 'jumpurl Secure: locationData, 50:_NO_TABLE:, was not accessible. '

<![CDATA[
10 = TEXT
10.if.isTrue.field = field_download
10.current = 1
10.trim = 1
10.filelink {
path = uploads/documents/
size = 1
size.bytes = 1
size.bytes.labels = “ |k|m|g”
size.wrap =  <span class="normal">( | )</span>
target = _blank
ATagParams = class="pdf"
labelStdWrap.override.field = field_file_label
labelStdWrap.override.if.isTrue.field = field_file_label
removePrependedNumbers = 1
jumpurl = 1
jumpurl.secure = 1
jumpurl.secure.mimeTypes = pdf=application/pdf
}
]]>

See discussion here:
http://lists.typo3.org/pipermail/typo3-project-templavoila/2007-February/001935.html

(issue imported from #M4982)

#1

Updated by Joh. Feustel almost 9 years ago

  • Target version deleted (0)

Still a valid problem. Still not possible to force pdf download instead of browser plugin with


10 = TEXT
10.typolink {
    parameter.field = field_pdf
    jumpurl = 1
    jumpurl.secure = 1
    jumpurl.secure.mimeTypes = pdf=application/force-download
}

Why is this issue in category "Communication"?

#2

Updated by Alexander Opitz over 7 years ago

  • Category deleted (Communication)
  • Status changed from New to Needs Feedback

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#3

Updated by Lukas Rüegg over 7 years ago

Alexander Opitz wrote:

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

I can't say – I haven't used jumpurls anymore (as they didn't work). However, I think it's still an issue because of the usage of the keyword "_NO_TABLE" in tslib_cobj::start:

$cObj->start($dataRecord,'_NO_TABLE');

This will break any usage of tslib_cobj which requires a valid table and appears to be an ad hoc, undocumented and unsupported keyword.

At any rate this beahaviour is still present in the latest TemplaVoila release so I'm guessing jumpurls will still not work in any version of TYPO3. Also, I don't think this is a TYPO3 issue, I think it's a TemplaVoila issue. The easiest solution would be to modify line 540 in class.tx_templavoila_pi1.php as follows:

$cObj->start($dataRecord);

–S

#4

Updated by Alexander Opitz over 7 years ago

So it would be nice to report this to TV => http://forge.typo3.org/projects/extension-templavoila/issues

#5

Updated by Lukas Rüegg over 7 years ago

Alexander Opitz wrote:

So it would be nice to report this to TV => http://forge.typo3.org/projects/extension-templavoila/issues

That's my opinion, yes. But Dmitry disagreed (http://lists.typo3.org/pipermail/typo3-project-templavoila/2007-February/001935.html).

#6

Updated by Alexander Opitz over 7 years ago

Ok,

as I don't see mentioned "_NO_TABLE" in TYPO3\CMS\Frontend\ContentObject\ContentObjectRenderer it seems this issue belongs to TYPO3 4.5?

#7

Updated by Lukas Rüegg over 7 years ago

Alexander Opitz wrote:

Ok,

as I don't see mentioned "_NO_TABLE" in TYPO3\CMS\Frontend\ContentObject\ContentObjectRenderer it seems this issue belongs to TYPO3 4.5?

It affects all versions of TYPO3 because the keyword _NO_TABLE is not a core feature, i.e. to my knowledge it is not implemented in any version of TYPO3. It was Dmitry's suggestion to add it to the core list. I did not agree with him, but as I originally reported the bug and he was the TV maintainer I added to the core list.

Perhaps it would be good to get Dmitry or someone from the TV team involved in this discussion...

#8

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to New

Hmmm, I see something in TYPO3\CMS\Core\Database\RelationHandler with _NO_TABLE for MM relations but it seems that hadn't to do with this issue. ;-)

#9

Updated by Mathias Schreiber about 6 years ago

  • Status changed from New to Closed
  • Is Regression set to No

Also available in: Atom PDF