Bug #17061

Mailform with localization ignores the email-address of the translated record

Added by Marcel Alburg over 15 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Category:
Communication
Target version:
-
Start date:
2007-03-01
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.0
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you've a FORM with different languages and different recipients (every language a other recipient) the FORM send's the mail always to the e-mail address which was entered in default language.

(issue imported from #M5104)


Files

mailForm_localized.patch (1.07 KB) mailForm_localized.patch Administrator Admin, 2007-03-01 17:09
bug_5104_stucki.diff (1.19 KB) bug_5104_stucki.diff Administrator Admin, 2009-04-29 12:11
#1

Updated by Marcel Alburg over 15 years ago

i'm sorry.

But this problem is for Typo3 4.0.x.

#2

Updated by Ferdinand Kuhl over 13 years ago

This is true for the current 4.2.6 release!
The added Patch solves the problem at its root. The form prints out the wrong ID in its locationData field. Why has this patch not been integrated yet?

#3

Updated by Ferdinand Kuhl over 13 years ago

(As the patch is quite old, I did not apply the patch, but used the informations in it to edit the tslib_content myself)

#4

Updated by Michael Stucki over 13 years ago

Ferdinand Smith: I acknowledge your solution which seems pretty nice and also works well. However, it is difficult to change the currentRecord since it is not defined whether it should contain the original or the translated record uid. It is likely that your fix would cause breakage at some place.

Instead I have uploaded another patch which fixes the issue without touching $this->currentRecord.

#5

Updated by Ferdinand Kuhl about 13 years ago

Thanks a lot. Works perfectly at my setup.

#6

Updated by Freddy Tripold over 11 years ago

This problem still exits with version 4.5.2, so why is this this bugfix not in the core?

#7

Updated by Chris topher over 11 years ago

I guess that issue got forgotten somehow. :-(

Can you please push it to Gerrit, so that it can be reviewed?
For more information see here: http://wiki.typo3.org/Git

#8

Updated by Gerrit Code Review over 10 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7817

#9

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/8957

#10

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/8958

#11

Updated by Michael Stucki over 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#12

Updated by Benni Mack almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF