Bug #17091

"No template found" after update from 4.0.4 to 4.1

Added by Jorgo S. over 12 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2007-03-07
Due date:
% Done:

0%

TYPO3 Version:
4.1
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The site http://chie.jorgo.org is based on the BUSINESS template. After updating to 4.1 source, message "No template found" is shown. Re-adding the template as static does not remedy the situation.

(issue imported from #M5157)


Related issues

Related to TYPO3 Core - Bug #17437: When accessing pages form cache "No Temlpate found!" appears Closed 2007-07-21
Related to TYPO3 Core - Bug #17053: cache is not saved properly Closed 2007-02-28
Related to TYPO3 Core - Bug #21569: Wrong character encoding in cache tables breaks frontend rendering Closed 2009-11-16
Related to TYPO3 Core - Feature #21525: No typoscript template found - Addon Closed 2009-11-10

History

#1 Updated by Michael Stucki over 12 years ago

That would mean that the ID of the static template has changed. Can you check this, please?

#2 Updated by Jorgo S. over 12 years ago

I'm sorry, let's pretend I'm a noob - what's the quickest way to check this?

#3 Updated by Michael Stucki over 12 years ago

You could have compared the IDs with those from your backup, but never mind, I misread your posting. Apparently your problem ist still existing since re-adding did not help.

Can you reproduce the whole thing on a different site?

#4 Updated by Jorgo S. over 12 years ago

Sorry again, I only have this one installation. I can give you access if needed.

#5 Updated by Michael Stucki over 12 years ago

If you want to help, then please set up a 2nd installation. I will not test this further before.

#6 Updated by Thomas Esders over 12 years ago

We got the same problem, but with no static template. Other updates went fine...

If you clear the cache, the first site is redered correctly. If you click on another site you get "No Template Found". If you clear the cache one again, you can see the other site.

We use "Page Template Selector" if this helps...

#7 Updated by Thomas Esders over 12 years ago

Hi!

Is this the same as 0005088?

#8 Updated by Sudara Williams - over 12 years ago

Hello.

I'm also getting this issue using templavoila.

Any update?

#9 Updated by Andreas Balzer over 12 years ago

Hi!
We (ess-erfurt.de) have exactly the same problem.
The page is visible as long as it is not cached. After the first page entry (which often shows only page type 0 (other pagetypes don't work) you only get "No template found".

If you are logged in as an admin and have FE panel enabled and activated you might have a chance to look at the page..

EDIT: It doesn't matter if your install tool update wizzard is in compatible mode to <=3.8 Even then the error occurs..

#10 Updated by Artyom over 12 years ago

Typo 4.1.1 is installed. Site completely in utf-8 (DB, forceCharset etc.)

When "subtitle" field in template contains Russian symbols "No template found!" is generated after page is cached.

To view the page it is necessary to clear the cache but on second page opening error will be displayed again. cache_hash.content is mediumblob in DB so the problem does not relate to 0005088

#11 Updated by Jorgo S. over 12 years ago

For me the problem has gone away after updating to 4.1.1. Site is completely in utf-8, languages english, spanish and japanese.

#12 Updated by Andrey Nikolaevich over 10 years ago

Change type of `content` field to longtext in`cache_hash` table, it helps.

#13 Updated by Stefan Frank over 10 years ago

Andreys hint works fine for me. The problem occurred while moving from server to another.
The database was exported (mysqldump) and imported (mysql) with --default-character-set=utf8
TYPO3 4.2.6, MySQL 5.0.75-0ubuntu10.2, PHP Version 5.2.6-3ubuntu4.1

#14 Updated by Steffen Kamper almost 10 years ago

resolved with #21569

Also available in: Atom PDF