Feature #17102

EM should inform admin if a local extension is outdated and needs an updated extension

Added by Oliver Hader over 12 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2007-03-09
Due date:
% Done:

0%

PHP Version:
4.3
Tags:
Complexity:
Sprint Focus:

Description

This issue is more related to system extension as to others.
Imagine a site was running TYPO3 4.0.1 for several month and e.g. the RTEhtmlarea was installed locally from TER (with security patches, etc.). Now the admin decides to update to TYPO3 4.1.0. The RTEhtml will not work anymore, because the local installation of this extension (made for TYPO3 4.0.x) is not compatible to TYPO3 4.1.0 anymore.

The Extension Manager (perhaps additionally the update wizard of the install tool) should inform the admin, that the newer system extension is required and that he has to uninstall his local extension.

Just read bug-id #17082 to see what could happen.

(issue imported from #M5178)


Related issues

Related to TYPO3 Core - Bug #17082: RTE does not load Closed 2007-03-06

History

#1 Updated by Anja Leichsenring over 6 years ago

  • Status changed from New to Rejected
  • Target version deleted (0)

System extensions are shipped with the Core, so a compatible version is always available.

Also available in: Atom PDF