Feature #17434

Allow more than one parent field pointing to the same children table with foreign_field

Added by Oliver Hader over 12 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2007-07-04
Due date:
% Done:

0%

PHP Version:
4.3
Tags:
Complexity:
Sprint Focus:

Description

The following field configuration of a parent record in TCE is currently not possible:

'columns' => array(
'firstchildren' => array(
'config' => array(
'type' => 'inline',
'foreign_table' => 'tx_myext_child',
'foreign_field' => 'parent',
),
),
'secondchildren' => array(
'config' => array(
'type' => 'inline',
'foreign_table' => 'tx_myext_child',
'foreign_field' => 'parent',
),
),
),

The reason is, that with foreign_field the children are selected by the table and the uid in the field 'parent'. Thus, the children are not identified to with field in the parent record they belong.

The feature request is to have a new TCA property likle 'foreign_fieldfield' that defines a field on the child side storing the fieldname of the parent record creating the child.

The attached extension "test_required" reproduces this behaviour.

(issue imported from #M5897)

T3X_test_required-0_0_0-z-200707041425.t3x (18.8 KB) Administrator Admin, 2007-07-04 14:25

History

#1 Updated by Beat Takeshi almost 12 years ago

+1!
This behaviour limits the reusability of child tables drastically.

If someone points me in the right directioin I would be willing to fix this, can't be that hard.

#2 Updated by Ingmar Schlecht over 11 years ago

I don't see the point.

Why do you use
'foreign_field' => 'parent',
for both of the fields?

I would propose to use
'foreign_field' => 'parent',
for the first field,

and use
'foreign_field' => 'daddy',
for the second field.

Of course, the child table would have to contain both fields "parent" and "daddy", but what's the problem? If that doesn't work - well, that's a bug. But conceptionally, I don't see why it should be possible to link to the same child table using the same parent pointer field twice!

Ingmar

#3 Updated by Niels Pardon over 10 years ago

In my opinion this is a duplicate of: http://bugs.typo3.org/view.php?id=7063

#4 Updated by Alexander Opitz about 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

Hi,

as this issue is very old. Is this feature missing in newer versions of TYPO3 CMS (6.1)?

#5 Updated by Alexander Opitz almost 6 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this ticket.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF