Bug #18111

"Clear all caches" doesn't delete temp_CACHED... files.

Added by Stefan Geith about 12 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2008-02-04
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

"Clear all caches" doesn't delete temp_CACHED... files.

But it seems intended, that it is a combination of
"Clear page content cache" and "Clear configuration cache".

So either "Clear all caches" is a misleading description of what it does and the naming should be changed or it's a bug, that should be fixed.

(issue imported from #M7378)


Related issues

Related to TYPO3 Core - Bug #18635: [Renaming] "clear all cache" to "Clear system cache" because of ext_localconf.php Closed 2008-04-18
Related to TYPO3 Core - Bug #18650: Clear all caches should clear configuration cache as well Closed 2008-04-20

History

#1 Updated by Stefan Geith about 12 years ago

IF "Clear all caches" should delete temp_CACHED... files, the solution is quite easy:

In File t3lib\class.t3lib_tcemain.php,
function clear_cacheCmd()
remove the break-command between "case 'all'" and "case 'temp_CACHED'"
in line 6964

#2 Updated by Stefan Geith about 12 years ago

I think, clear all caches should also clear the configuration cache.
What do you think ?

#3 Updated by Christian Kuhn over 11 years ago

This is related to #18635 and #18635.

Solution was to clear config cache in "Clear all cache", too.

Bug should be closed.

Also available in: Atom PDF