Bug #18605

defect wsid check in workspace-overlay delivering wrong record versions from DB!

Added by Franz Koch over 11 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2008-04-11
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The method t3lib_BEfunc::workspaceOL is using a defect check for the current workspace-id with the following sideeffect:

When you have a page in various versions (through versioning) and are working in LIVE-Workspace, the method will overlay the current live version of the record with a older, outdate version.

This happened to me, when I was trying to fetch a pageTS for a certain page and the setting I needed to check did not show up although I defined it in pageTS. Then I started debugging and found this bug.

Sidenote: I set the TYPO3-version for this bug to 4.2 in order to get that fixed for 4.2, but the bug itself is also present in 4.1.5 and probably some versions earlier.
(issue imported from #M8092)

patch.diff View (531 Bytes) Administrator Admin, 2008-04-11 12:57

History

#1 Updated by Franz Koch over 11 years ago

Update:
the patch is now obsolete. The problem is still the same, but it resides on a different place as I've found out. So the patch was merly 'fixing' one symptom instead the actual cause. I've to dig deeper in the core to find the place where the method t3lib_befunc::workspaceOL is called, but the workspaces are not initiated to that point and thus cause the error. Maybe somebody could give a hint?

#2 Updated by Andreas Wolf about 10 years ago

Could you please provide some concise steps to reproduce this problem? I have an idea of how to do this, but I'm not sure if it is correct. And also give a more detailed description of how exactly you found this bug (i.e., what did you do?).

When you try to solve the issue, you could echo t3lib_div::debug_trail() in t3lib_BEfunc::workspaceOL() to show which functions where called before. If you need more detailed information, print_r(debug_backtrace()) could help, but this may be quite huge.

#3 Updated by Tolleiv Nietsch about 8 years ago

  • Status changed from New to Closed
  • Target version deleted (0)

Had no feedback for ages. Please open a new bug once this gets relevant again.

#4 Updated by Michael Stucki about 6 years ago

  • Category set to Workspaces

#5 Updated by Michael Stucki about 6 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces

Also available in: Atom PDF