Bug #18734

SQL debug output is not shown in the Backend

Added by Mario Rimann over 12 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2008-05-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I have SQL debug output enabled in the Install Tool which works really good. But after upgrade from 4.1.6 to 4.2.0, there is a problem with the debug output: It's shown "behind" other stuff from the BE. Through this, the debug output is not readable (one just sees the red borders - but not the contents of the message as it's hidden behind the other stuff from the BE).

As the error message is completely available when I look at the HTML source, I think this is just a CSS issue.

(issue imported from #M8305)


Files

8305_debugOut.diff (14.4 KB) 8305_debugOut.diff Administrator Admin, 2008-05-02 10:39
8305_error.png (60.8 KB) 8305_error.png Administrator Admin, 2008-05-03 12:56
debug_error_BE.png (20.9 KB) debug_error_BE.png Administrator Admin, 2008-05-19 00:35
docheader_debug_problem.diff (411 Bytes) docheader_debug_problem.diff Administrator Admin, 2008-05-19 00:35
sql_error_patch.png (35 KB) sql_error_patch.png Administrator Admin, 2008-10-31 12:34
8305_v1.diff (6.34 KB) 8305_v1.diff Administrator Admin, 2010-04-30 22:37

Related issues

Related to TYPO3 Core - Bug #21570: Debug output destroys BE HTMLClosedSteffen Kamper2009-11-16

Actions
Related to TYPO3 Core - Bug #21557: Use flash messages to show SQL debug errors in the backendClosedSteffen Kamper2009-11-15

Actions
Related to TYPO3 Core - Bug #18220: typo3-docheader not visible when error occuresClosedSteffen Kamper2008-02-15

Actions
Related to TYPO3 Core - Feature #22723: hundreds of SQL debugs are unusableClosed2010-05-26

Actions
Related to TYPO3 Core - Bug #28083: Some unit tests fail with "Cannot modify header information"ClosedXavier Perseguers2011-07-11

Actions
Has duplicate TYPO3 Core - Feature #17945: error messages are hidden with new TCEClosedChris topher2007-12-22

Actions
#1

Updated by Mario Rimann over 12 years ago

I just had another look in to that issue and see two possibilities to fix it:

- change the CSS in a way that it allows content like the SQL debug output to be shown
- change the TYPO3 Core in a way that the SQL debug stuff is returned within the div#typo3-docbody.

#2

Updated by Steffen Kamper over 12 years ago

I did a patch that change debug in this way:

- t3lib_div::debug doesn't echo but collect debug info in $GLOBALS['debugOut']
- template.php fills marker ###DEBUG### with $GLOBALS['debugOut']
- possibility to supress all debugs with $GLOBALS['noDebug'] = 1
- placed ###DEBUG### in all BE-templates behind ###CONTENT###

- placed $GLOBALS['debugOut'] in FE after admin panel

#3

Updated by Mario Rimann over 12 years ago

I applied the patch to my TYPO3 Core and tried again. But I get the same problem again. Please see the attached screenshot of the problem.

#4

Updated by Steffen Kamper over 12 years ago

i think i found a very easy solution, please test it in your browsers

See last patch and screenshot, where i did a debug and implemented a line producing php warning.

#6

Updated by Ingo Renner over 12 years ago

@Steffen looks simple!

#7

Updated by Steffen Kamper over 12 years ago

@Ingo does it work for you on Mac/Safari?

#8

Updated by Ingo Renner over 12 years ago

didn't test

#9

Updated by Steffen Kamper over 12 years ago

ok, but Francois did, so it works on FF /IE7/IE6 and Safari (Mac)

I will make a RFC and glad to have this issue fixed.

#10

Updated by Rob Vonk about 12 years ago

This patch removes the scrollbar for long records. See attached image ( sql_error_patch.png)

#11

Updated by Steffen Kamper about 12 years ago

yeah, that was the reason why i gave up for the moment

#12

Updated by Stefan Galinski over 10 years ago

The attached patch fixes the issue by introducing a debug console based upon ExtJs and the currently introduced TYPO3 Viewport.

#13

Updated by Steffen Kamper over 10 years ago

Committed to trunk, rev 7486

Also available in: Atom PDF