Bug #18964

"Toggle selection" and "Import selection" in element browser do not work with Firefox 3

Added by Helmut Hummel over 13 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-06-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The mentioned options do not work in FF3 because the Element.getElementsByClassName function throws an error. This is a known issue concerning prototype and FF3; see:
http://ejohn.org/blog/getelementsbyclassname-pre-prototype-16/

Solution:
replace Element.getElementsByClassName call with Elment.select as proposed in the document above.
(issue imported from #M8720)


Files

bug_8720.diff (450 Bytes) bug_8720.diff Administrator Admin, 2008-06-15 15:51

Related issues

Is duplicate of TYPO3 Core - Bug #18965: getElementsByClassName does not work properly in Firefox 3 and Safari 3.1ClosedOliver Hader2008-06-16

Actions
#1

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF