Bug #19086

extension manager crashes without warning/error if a em_conf.php has parser error (function getInstExtList and includeEMCONF)

Added by Jonas Felix about 13 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2008-07-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If any em_conf.php file has a parser error, the extension manager crashes without warning. There is no Output shown at all.

In addition the errors are suppressed, even if you enable all errors and display_errors in PHP nothing is shown.

This way it's realy hard to find the fucked up extension config.

There should be some error if the inclusion file isn't working within function includeEMCONF()
(issue imported from #M8942)

#1

Updated by Steffen Kamper about 13 years ago

Error supression in EM is for some reasons, mainly for the soap communication with TER.

Do you found any extension in TER with broken em_conf?
Can you describe where exectly EM crashes (which option)

#2

Updated by Oliver Hader about 13 years ago

This is sometimes a real problem. Also if dependencies did not match - for whatever reasons. On some webhosters the error output is disabled by default and then it's really hard to track down the error...

#3

Updated by Jonas Felix about 13 years ago

It was a selfmade fatal error :-), I changed something in the em_conf.php in one of our extensions. Just a typo...

What about using devlog or what about checking if it's backend module and then output a regular t3 error? So the soap interface is not influenced?

#4

Updated by Martin Kutschker about 13 years ago

Error suppression sucks, error handling rules. Steffen, is it easy to remove the error suppression for SOAP and use @ with proper error handling (ie checking results before usin them!)

#5

Updated by Jonas Felix about 13 years ago

In 4.3 will be exception handling isn't it? And in addition you could do devlog?

It would be great if people pushes devlog, there is a great backend module for it and it's working.

#6

Updated by Alexander Opitz about 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#7

Updated by Alexander Opitz almost 8 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

#8

Updated by Jonas Felix almost 8 years ago

It's still an issue in all versions, that everything crashes if there is a parser error in a ext_emconf.php

Also available in: Atom PDF