Bug #19624

RTEhtmlarea does not work with IRRE after new child records were created

Added by Oliver Hader almost 11 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-11-21
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

RTEhtmlarea does not work anymore with IRRE after new child records were created while editing the parent record.

The reason is that loading JavaScript libraries in RTEhtmlarea has changed. For IRRE disposal it's required, that these libraries are only loaded with the parent record. Otherwise each newly created child record will load these files again and break the JavaScript functionality.

(issue imported from #M9807)

0009807_4-2.patch View (1.1 KB) Administrator Admin, 2008-11-21 13:02

0009807_trunk.patch View (1.03 KB) Administrator Admin, 2008-11-21 13:02


Related issues

Related to TYPO3 Core - Bug #19435: htmlARea RTE: Move link tags to head Closed 2008-10-08
Related to TYPO3 Core - Bug #18690: Creating and editing of fields, forms, etc. in FCE's is impossible if there is a section inside Closed 2008-04-24
Duplicates TYPO3 Core - Bug #19477: RTE does not work in IRRE subelements Closed 2008-10-17

History

#1 Updated by Stanislas Rolland almost 11 years ago

Fixed in SVN TYPO3core branch TYPO3_4-2 (revision 4670) and trunk (revision 4556).

#2 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF