Bug #19897

Bad interaction between OpenId auth and ExtJS relogin box

Added by Francois Suter almost 12 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2009-01-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The interaction of the OpenID authentication and the new relogin box in the current Trunk version is far from optimal. Indeed when you type your OpenID address in the login field a new window pops up with both a "Continue" and a "OK" button. This is quite confusing.

Clicking on the "Continue" button lets the process flow and all is fine. Clicking on "OK" brings you back to the relogin window. But clicking on "Login" again in this case results in a failed authentication (and trying again a bit later, brings up the second popup again).

This needs to be fixed. Do we need to take into account that some auth methods may need to have additional user interaction?

(issue imported from #M10244)


Related issues

Related to TYPO3 Core - Feature #19152: Remove JS popup when login expiredClosedOliver Hader2008-07-25

Actions
Related to TYPO3 Core - Bug #33759: AJAX login doesn't work with RSAauth and Salted passClosed2012-02-08

Actions
Is duplicate of TYPO3 Core - Bug #20038: AJAX relogin does not workClosedSteffen Kamper2009-02-17

Actions
#1

Updated by Steffen Kamper almost 12 years ago

i think we need a switch for the relogin thingy to deactivate it.
It could be deactivated automatically when openID is used.

I will test it with openID to get an idea.

#2

Updated by Dmitry Dulepov almost 12 years ago

In fact I would love to get rid of relogin at all. I do not see why we need it.

#3

Updated by Christoph Koehler almost 12 years ago

I like the relogin. I am sure we can optimize it in the case of other auth services.....
I am okay with an option to disable it though.

#4

Updated by Oliver Hader about 11 years ago

This was touched in issue #20038

Also available in: Atom PDF