Bug #20062

Crash in the FE in 4.2.x branch (regression)

Added by Oliver Klee over 12 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Communication
Target version:
-
Start date:
2009-02-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If I open my start page in the FE, I get the following error:

Fatal error: Cannot use string offset as an array in /home/klee/eclipse/TYPO3_4-2/typo3/sysext/cms/tslib/class.tslib_fe.php on line 713

This occurs independent of whether simulateStaticDocuments or realURL is enabled.

The problem only occurs on the current 4.2.x branch, not on the trunk or on the version tagged as 4.2.6. So this seems to be a recent regression.
(issue imported from #M10504)


Files

0010451_followup.patch (712 Bytes) 0010451_followup.patch Administrator Admin, 2009-02-20 16:09
0010452_followup.patch (731 Bytes) 0010452_followup.patch Administrator Admin, 2009-02-20 16:09

Related issues

Related to TYPO3 Core - Bug #20026: Evaluation PATH_INFO in tslib_fe::checkAlternativeIdMethods() sets false positivesClosedOliver Hader2009-02-16

Actions
Related to TYPO3 Core - Bug #20027: Evaluation PATH_INFO in tslib_fe::checkAlternativeIdMethods() sets false positives and should be moved to tx_simulatestaticClosedOliver Hader2009-02-16

Actions

Also available in: Atom PDF