Bug #20105

Clickmenu doesn't work with IE8

Added by Steffen Gebert over 8 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2009-02-27
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Clickmenu doesn't work in IE8 (version 8.0.7000.0)

This blocks backend.

Branches: 4.1 - 4.3

4.1 displays menu in upper frame, so it doesn't totally block, but also no nice behavior.

Error:
object doesn't support property or method (translated german message)
URI: http://www.example.org/typo3/js/clickmenu.js
Line 74: top.loadTopMenu(this.clickURL + '?' + params);

(issue imported from #M10566)


Related issues

Related to Core - Bug #18653: top.loadTopMenu undefined Closed 2008-04-21
Duplicates Core - Bug #20106: Get rid of browser version dependent t3lib_div::clientInfo() Closed 2009-02-28

History

#1 Updated by Steffen Gebert over 8 years ago

See #20106 for fix.

This is NOT an IE problem.. it's browser detection of TYPO3

#2 Updated by Ruben Sutter over 8 years ago

The compatibility mode in IE8 can be used as a workaround for this problem.

When working in the typo3 backend just switch the compatibility mode in IE 8 on and clickmenu should work fine.

#3 Updated by Ingo Renner over 8 years ago

fixed in 4.0.13, 4.1.11, 4.2.7, 4.3.0alpha3

#4 Updated by Martin Kutschker over 8 years ago

Cannot find an entry for this bug in the Changelogs!!! See also #18653.

#5 Updated by Michael Stucki over 8 years ago

Yeah because the fix was part of #20106.

#6 Updated by Michael Stucki over 8 years ago

Can we close this issue?

#7 Updated by Steffen Gebert about 8 years ago

yes, please!

#8 Updated by Michael Stucki about 8 years ago

This bug was already fixed some time ago.

Also available in: Atom PDF