Feature #20395

Optimize loading of frontend user groups

Added by Oliver Hader about 11 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2009-05-06
Due date:
% Done:

0%

PHP Version:
5.2
Tags:
Complexity:
Sprint Focus:

Description

In TSFE frontend user groups are tried to be loaded. However, if there's no active frontend user or no request for simulating a frontend user group, it does not make any sense to call tslib_fe->initUserGroups().

(issue imported from #M11038)

0011038.patch View (804 Bytes) Administrator Admin, 2009-05-06 20:08

History

#1 Updated by Oliver Hader about 11 years ago

Committed to SVN Trunk (rev. 5451)

#2 Updated by Rupert Germann about 11 years ago

doesn't work - please revert:

the call to initUserGroups() calls fe_user->fetchGroupData() which is indeed
an expensive operation but it also sets the vars "$this->loginUser"
and "$this->gr_list".

especially gr_list is used at many places and it is not set anymore now.
One effect of this missing gr_list is, that the complete "enableFields"
stuff works differently -> means f.e. that a function like
cobj->getTreeList seems to ignore the "$depth" parameter. This is caused by
a call to $GLOBALS['TSFE']->checkEnableFields() which expects a gr_list.

#3 Updated by Steffen Kamper about 11 years ago

i reverted it

#4 Updated by Xavier Perseguers almost 9 years ago

  • Category deleted (Communication)
  • Target version deleted (4.6.0-beta1)

#5 Updated by Alexander Opitz about 7 years ago

Is this still a problem in newer TYPO3 CMS versions?

#6 Updated by Alexander Opitz almost 7 years ago

  • Status changed from Needs Feedback to Closed

No feedback for over 90 days.

Also available in: Atom PDF