Bug #20396

Simulating frontend user groups via admin panel does not work

Added by Oliver Hader about 11 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Communication
Target version:
-
Start date:
2009-05-06
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The admin panel has a functionality to simulate frontend user groups (Admin Panel > Preview). However, the submitted value is not set corretly to BE_USER->uc and the simulation does not work at all.

(issue imported from #M11039)

0011039.patch View (964 Bytes) Administrator Admin, 2009-05-23 16:13


Related issues

Related to TYPO3 Core - Bug #20494: Access-restriction behaves identical for non-recursive/recursive Closed 2009-05-22
Duplicated by TYPO3 Core - Bug #20487: FE-Group simulation doesn't work Closed 2009-05-22

History

#1 Updated by Niels Fröhling about 11 years ago

The trigger-code for the preview is in:

typo3/sysext/cms/tslib/class.tslib_fe.php: 792 determineId()

All the involvement of the preview-options in page-rendering happens there, I'm looking for the failure there, maybe I find an easy fix.

#2 Updated by Niels Fröhling about 11 years ago

$GLOBALS['BE_USER']->frontendEdit

Is not set [isset is false] when entering the function ...

#3 Updated by Niels Fröhling about 11 years ago

Okay, the reason is priority-inversion:

typo3/sysext/cms/tslib/index_ts.php: 317+

"$TSFE->determineId()" is called before "$BE_USER->initializeFrontendEdit()"

In 4.2.0 the order was inversed:

typo3/sysext/cms/tslib/index_ts.php: 226+

"t3lib_div::makeInstance('t3lib_tsfeBeUserAuth')" was called before "$TSFE->determineId()"

I don't know if per-se the FE-init block can be moved before the workspace-preview-init. I am not so clear in which way the priorities are inter-mingled there ...

#4 Updated by Oliver Hader about 11 years ago

Hi Niels, thanks for pointing it out. I came to the same conclusion. Since the adminPanel was extracted from tsfeBeUserAuth, it has to be initialized explicitely before TSFE->determineId().

#5 Updated by Oliver Hader about 11 years ago

Committed to SVN Trunk (rev. 5488)

Also available in: Atom PDF