Bug #20487

FE-Group simulation doesn't work

Added by Niels Fröhling about 12 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2009-05-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The activation of FE-Group simulation in the admin-panel doesn't do a thing.

- It doesn't hide content elements which supposly should disappear (access: hide on login)
- It throws you out of FE-group protected pages down to the first unprotected (access: fe-group, incl. sub-pages)

(issue imported from #M11163)


Related issues

Is duplicate of TYPO3 Core - Bug #20396: Simulating frontend user groups via admin panel does not workClosedOliver Hader2009-05-06

Actions
#1

Updated by Niels Fröhling about 12 years ago

This extends to the Web->View module as well. If you configure the admin-panel to be shown and restrict edit-access to a page which is inside a FE-group protected tree, you get thrown down the tree to the first unprotected page. Even if the FE-group simulation would function you couldn't make it active because you'll never see the admin-panel to give you that option.

#2

Updated by Michael Stucki about 12 years ago

I'm not sure if I understand you correctly. Is the TypoScript for enabling the admin panel on a page which is accessible, or not?

#3

Updated by Michael Stucki about 12 years ago

One more thing: I remember there was a bug that turned the changes to the admin panel active always on the 2nd load. Please try to open one more page and check if the admin panel changes will take effect.

#4

Updated by Oliver Hader about 12 years ago

Duplicate of #20396

#5

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF