Bug #21043

itemsProcFunc for Radio-Buttons doesn't work correctly

Added by David Bruchmann about 11 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-09-12
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

itemsProcFunc for Radio-Buttons should work as the same function for select-fields. The difference is that for Radio-Buttons the same amount of dummy-arrays as estimated items has to be noted.

At first a working example for select:

$tempColumns = array (
FIELDNAME => array(
'exclude' => 1,
'label' => LABEL,
'config' => array (
'type' => 'select',
'items' => Array(
array('', 0),
),
'itemsProcFunc' => CLASS->FUNCTION,
'default' => 0,
),
),
);

For Radio-Buttons the same Array has to be noted like that:

$tempColumns = array (
FIELDNAME => array(
'exclude' => 1,
'label' => LABEL,
'config' => array (
'type' => 'radio',
'items' => Array(
array('', 0),
array('', 1),
array('', 2),
....
),
'itemsProcFunc' => CLASS->FUNCTION,
'default' => 0,
),
),
);

So the amount of estimated items has to be verified earlier which requires to include another function with the same requests two times.

(issue imported from #M11935)


Related issues

Related to TYPO3 Core - Bug #53928: itemsProcFunc for Radio-Buttons doesn't work correctly Closed 2013-11-25

History

#1 Updated by Alexander Opitz over 7 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#2 Updated by Alexander Opitz about 7 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

#3 Updated by Uwe Wiebach almost 7 years ago

I guess this is still an issue with 6.2 master. At least if I interpret it correct:

If a radio button is filled with itemsProcFunc, the value check (function checkValue_radio in DataHandler.php) fails as it only test the items-array ...

Also available in: Atom PDF