Bug #21490

PHP-5.3: Invalid UTF-8 sequence in argument

Added by Dan Osipov about 12 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2009-11-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

[06-Nov-2009 20:10:24] http://phillyburbs/ - Core: Error handler (BE): PHP Warning: json_encode() [<a href='function.json-encode'>function.json-encode</a>]: Invalid UTF-8 sequence in argument in C:\wamp\www\pb_trunk\typo3\sysext\rtehtmlarea\class.tx_rtehtmlarea_base.php line 1224

I think this is comming from several language files that have non-UTF8 (certainly non-english) characters:
locallang.xml:
<label index="Technische Universitat Ilmenau">Technische Universität Ilmenau</label>

(issue imported from #M12501)


Files

12501.patch (1.49 KB) 12501.patch Administrator Admin, 2009-11-09 14:34
#1

Updated by Rupert Germann about 12 years ago

which extension has this label?

#2

Updated by Dan Osipov about 12 years ago

rtehtmlarea

#3

Updated by Stanislas Rolland about 12 years ago

Can you identify the offending file? I could not find any that is not utf-8-encoded.

#4

Updated by Dan Osipov about 12 years ago

Stan - attached patch fixes the problem for me.

#5

Updated by Stanislas Rolland about 12 years ago

@Dan: I do not understand this patch. The same label exists in other files (CopyPaste, DefinitionList).

#6

Updated by Dan Osipov about 12 years ago

Maybe they aren't loaded for me? Its definitely the a-umlaut that causes the issue on my installation though.

Some other files just use a latin "a" - can it be used throughout?

#7

Updated by Stanislas Rolland about 12 years ago

If you are referring to trunk and have copy, cut or paste button, then the CopyPaste file would be loaded.

The index uses latin a, the label ä. But the file being utf-8 encoded like all locallang.xml files, why should it matter?

#8

Updated by Dan Osipov about 12 years ago

I don't know - its beyond me... It would be nice if someone else could replicate the bug.

#9

Updated by Stanislas Rolland about 12 years ago

Is the backend of your installation utf-8 encoded?

#10

Updated by Dan Osipov about 12 years ago

I have:
$TYPO3_CONF_VARS['BE']['forceCharset'] = "utf-8";

Is there anything else that needs to be done?

#11

Updated by Stanislas Rolland about 12 years ago

No, that's fine.

#12

Updated by Stanislas Rolland almost 12 years ago

Please test patch attached to issue #12926.

#13

Updated by Chris topher almost 12 years ago

Stan, this is part of issue #12926.
Since you have solved that one, this one is solved, too.

#14

Updated by Stanislas Rolland almost 12 years ago

@Christopher: This is the assumption. But I would like Dan to confirm that this issue is solved in his environment also.

The patch is now in SVN.

#15

Updated by Dan Osipov almost 12 years ago

Stanislas Rolland:
I am unable to replicate the bug with the latest trunk, so I believe the issue was fixed by the patch.

Thanks a lot!!

#16

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF