Bug #21587

Warnings in BE when using the "Full search" in module "DB check"

Added by Georg Ringer over 11 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-11-17
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When performing an search in the module "DB check" > Full search > "Raw search in all fields" the following warnings are produced:

  • PHP Warning
    PHP Warning: reset() [function.reset]: Passed variable is not an array or object in C:\xampp\htdocs\currenttrunk\t3lib\class.t3lib_fullsearch.php line 578
  • PHP Warning
    PHP Warning: Variable passed to each() is not an array or object in C:\xampp\htdocs\currenttrunk\t3lib\class.t3lib_fullsearch.php line 580

can someone reproduce this with latest trunkt too?

(issue imported from #M12635)

#1

Updated by Dmitry Dulepov over 9 years ago

  • Target version deleted (0)

The cause is the same as for #21590: missing table in the database, which is declared in $TCA.

I guess we should close this.

#2

Updated by Georg Ringer almost 9 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

not reproduceable any more

#3

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF