Bug #21590

Warnings in BE when using "Update reference index"

Added by Georg Ringer over 11 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-11-17
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When I update the reference index in the backend by clicking DB check > manage reference index > update now I get this warning

PHP Warning
PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\currenttrunk\t3lib\class.t3lib_refindex.php line 1022

using latest trunk

(issue imported from #M12639)


Files

12639.diff (1.59 KB) 12639.diff Administrator Admin, 2009-11-25 19:08
#1

Updated by Rupert Germann over 11 years ago

works for me here. no warnings
Does db-compare find something to update in your installation?

#2

Updated by Georg Ringer over 11 years ago

db compare doesnt help, sorry to mention

#3

Updated by Georg Ringer over 11 years ago

checked with fresh installation, works now - close it?

#4

Updated by Georg Ringer over 11 years ago

sry still not working, of course $TYPO3_CONF_VARS['SYS']['displayErrors'] = '1'; is necessary ....

#5

Updated by Steffen Müller over 11 years ago

Cannot reproduce. I see no warning. Using trunk rev. 6546

#6

Updated by Steffen Kamper over 11 years ago

it's difficult to reproduce as everyone has different data in.
I see no reason not to check array before foreach(), see patch

#7

Updated by Mr. Jenkins over 9 years ago

  • Status changed from New to Under Review

Patch set 1 of change I29bca987a7897530a383b30b19bd8cfa008afd57 has been pushed to the review server.
It is available at http://review.typo3.org/6874

#8

Updated by Mr. Jenkins over 9 years ago

Patch set 2 of change I29bca987a7897530a383b30b19bd8cfa008afd57 has been pushed to the review server.
It is available at http://review.typo3.org/6874

#9

Updated by Dmitry Dulepov over 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#10

Updated by Gerrit Code Review over 9 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/7109

#11

Updated by Gerrit Code Review over 9 years ago

Patch set 2 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/7107

#12

Updated by Gerrit Code Review over 9 years ago

Patch set 2 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/7109

#13

Updated by Dmitry Dulepov over 9 years ago

  • Status changed from Under Review to Resolved
#14

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF