Bug #21592

Warnings in BE when using "Datebase Relation"

Added by Georg Ringer over 11 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-11-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

when using db check > database relation I get the following warnings:
PHP Warning
PHP Warning: reset() [function.reset]: Passed variable is not an array or object in C:\xampp\htdocs\currenttrunk\t3lib\class.t3lib_admin.php line 416
PHP Warning
PHP Warning: Variable passed to each() is not an array or object in C:\xampp\htdocs\currenttrunk\t3lib\class.t3lib_admin.php line 417

using the latest trunk

(issue imported from #M12641)

#1

Updated by Rupert Germann over 11 years ago

works for me here.
Does db-compare find something to update in your installation?

#2

Updated by Georg Ringer over 11 years ago

doesnt help, i will investigate the next days

#3

Updated by Rupert Germann over 11 years ago

any environment specialities? php 5.3, windows, ... or other exotic stuff? ;-)

#4

Updated by Georg Ringer over 11 years ago

5.2, xp, nothing strange

#5

Updated by Georg Ringer over 11 years ago

works now with a fresh installation

#6

Updated by Georg Ringer over 11 years ago

sry still not working, of course $TYPO3_CONF_VARS['SYS']['displayErrors'] = '1'; is necessary ....

#7

Updated by Steffen Müller over 11 years ago

works for me, rev. 6546

#8

Updated by Steffen Kamper over 11 years ago

georg, i think any extension delivers invalid code or invalid SQL or something simular. Could you check which one is responsile? The warning here doesn't help much if we don't know which data exactly fails.
So it would help to give a better error message with description here.

#9

Updated by Georg Ringer over 11 years ago

thanks for the hint, the bad guy is direct_mail :/

#10

Updated by Alexander Opitz almost 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

As this report is very old, is the handling in newer TYPO3 CMS Versions (like 6.0/6.1) more like you expect it?

#11

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF