Bug #21849

When configuring to remove Edit menu from clickmenu, it also removes 'Edit Page Properties'

Added by Kasper Ligaard about 11 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-12-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

According to the TS Config manual you can configure the User TSConfig entry contextMenu.[key].disableItems with either (or both) af edit and edit_pageheader.

If adding 'edit' then 'edit_pageheader' is also removed because the code (wrongly) test whether the variable editPageIconSet is set. Removing the check, which is done in the attached patch file, solves the problem and makes things work as documented in the TS Config manual.

There is a closely related problem: The entry is not called 'edit_pagehader' anymore (and has not been called that since 2005!!!). It is now called 'edit_pageproperties'. This needs to be corrected in the manual, i.e. replacing 'edit_pageheader' with 'edit_pageproperties' in the description of the configuration entry for contextMenu.[key].disableItems.

TS Config manual: http://typo3.org/documentation/document-library/core-documentation/doc_core_tsconfig/4.2.0/view/1/2/#id4138422
(issue imported from #M13022)


Files

typo3bug-menuconfig-disableitems.patch (937 Bytes) typo3bug-menuconfig-disableitems.patch Administrator Admin, 2009-12-12 19:27

Related issues

Related to TYPO3 Core - Bug #22629: TSConfig manual "contextMenu.pageTree.disableItems =moreoptions" remove also “hide”Closed2010-05-11

Actions
#1

Updated by Benni Mack about 11 years ago

Hey Kasper,

well, the option $backRef->editPageIconSet is set by alt_clickmenu.php because it checks if the page can be edited. thus it should be kept. Although our patch solves your problem, I think the change needs to be in another area. What do you think?

Btw: Thanks for the spot in the documentation, I'll let Francois Suter know so he can take care of it.

Thanks for your work.

#2

Updated by Alexander Opitz over 7 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

As this report is very old, is the handling in newer TYPO3 CMS Versions (like 6.0/6.1) more like you expect it?

#3

Updated by Riccardo De Contardi over 7 years ago

Since 4.5 Context menu have only the "Edit" item so I guess this can be closed

#4

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback from author for over 90 days.

Also available in: Atom PDF