Bug #21934

some bugfixes for IRRE (Localisazion + Selector + Encoding)

Added by Martin Borer over 10 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-08-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi There,

I've attached a patch with some small bugfixes for IRRE.

1. There were no localisazion links if selector is enabled.

2. Selected Items were not removed from selector. There was a bug in the setUnique function of jsfunc.inline.js

3. deactivated utf8-encoding for ajax loaded inline records, they were encoded twice. I'm not sure if this bug is realy fixed!!! For me it's working...

Greets
Martin

(issue imported from #M15380)


Files

irre_bugfixes_rev8156.diff (6.21 KB) irre_bugfixes_rev8156.diff Administrator Admin, 2010-08-06 19:20

Related issues

Related to TYPO3 Core - Bug #18269: "foreign_selector" option and localization links doesn't workClosedOliver Hader2008-02-21

Actions
Related to TYPO3 Core - Bug #21102: IRRE: Selected items not removed from selector when foreign_unique is setClosedStanislas Rolland2010-08-09

Actions
Related to TYPO3 Core - Bug #23160: Ajax loaded items of inline records are encoded twiceClosedSteffen Kamper2010-07-12

Actions
#1

Updated by Steffen Gebert over 10 years ago

Hi Martin,

thanks for your patch!

Could you split up your patch and create single issues for every problem, you solve?
Afterwards, it would be perfect to send the patches to the core mailing list, to get this into the TYPO3 core.

Please read the HOWTO here: http://typo3.org/teams/core/core-mailinglist-rules/ or here: http://typo3blogger.de/ab-in-den-core/ (german)

Steffen

#2

Updated by Pierre Rouwens about 10 years ago

Hi
has this been released yet ?

#3

Updated by Steffen Gebert about 10 years ago

No, of course not, if you know, which part belongs to which issue and can reporduce it, it would be cool, if you could take care and open a new Bug tracker entry for every issue, attach the patch and send it to the core team list.
As I'm not so familar with IRRE, please don't expect any action from my side - I only try to coordinate this issue.

#4

Updated by Pierre Rouwens about 10 years ago

Hi,
Well I've been able to reproduce the double utf8 encoded and have applied only partial patch. I can send a patch to the core mailing list if you want. I should be able to do this by the end of the week.

#5

Updated by Steffen Gebert about 10 years ago

This issue is already fixed in #23160, to be released in 4.4.3

#6

Updated by Pierre Rouwens about 10 years ago

OK good :)

#7

Updated by Martin Borer about 10 years ago

Have already splited the 3 Parts in 3 different bug reports...

selected items not removed from selector
http://bugs.typo3.org/view.php?id=15400

Ajax loaded items of inline records are encoded twice
http://bugs.typo3.org/view.php?id=15092

"foreign_selector" option and localization links doesn't work
http://bugs.typo3.org/view.php?id=7611

You will also find there the links to the Patch requests...

#8

Updated by Steffen Gebert about 10 years ago

Resolved as duplicate

#9

Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF