Bug #22203

MENU.showAccessRestrictedPages.addParams generates wrong URLs

Added by Thomas Schröder over 9 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2010-02-26
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

We want to show restricted pages. TSREF [http://typo3.org/documentation/document-library/references/doc_core_tsref/4.1.0/view/10/1/] says:

showAccessRestrictedPages = 123
showAccessRestrictedPages.addParams = &return_url=###RETURN_URL###&pageId=###PAGE_ID###

But the generated URLs look like:
www.domain.org/login/?return_url=login/%3Freturn_url%3Dmysecretpage%252F%26pageId%3D176&pageId=176

The correct URL should be:
www.domain.org/login/?return_url=mysecretpage/&pageId=176

Tested with 4.3 branch.

(issue imported from #M13683)


Related issues

Related to TYPO3 Core - Bug #25140: RETURN_URL in menus is not created correctly Closed 2011-02-23

History

#1 Updated by Josef F. Glatz (Old User) about 7 years ago

  • Target version changed from 0 to 4.7.1

Hi forge,

I tried to use the showAccessRestrictedPages stuff but without success. The value of the return_url is empty in TYPO3 4.6.x

Not only, that I would need this function... I think this is an important feature for a CMS like TYPO3.

Is there any workaround, how to solve this? Is this feature available in near future ?

Cheers,
jousch

#2 Updated by Josef F. Glatz (Old User) about 7 years ago

  • Target version changed from 4.7.1 to 6.0.0

#3 Updated by Torben Hansen about 5 years ago

I could finally solve the "problem" (tested with TYPO3 6.2.4).

First of all, you should configure TYPO3 to create typolinks for access restricted pages like shown below.

config.typolinkLinkAccessRestrictedPages = {$loginPid}
config.typolinkLinkAccessRestrictedPages_addParams = &redirect_url=###RETURN_URL###

Just replace {$loginPid} with the uid of your login page. Without this setting, the return_url will be blank.

Next, configure your Menu object with the following

1 = TMENU
1.showAccessRestrictedPages = NONE

So maybe the issue is not to be related to a bug in TYPO3, but a misconfiguration in your TypoScript.

#4 Updated by Riccardo De Contardi about 4 years ago

  • Description updated (diff)
  • Category deleted (Communication)
  • Status changed from New to Closed
  • Is Regression set to No

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF