Feature #22249

Custom Workspaces allow users file mounts

Added by Darren Clark about 12 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2010-03-07
Due date:
% Done:

0%

Estimated time:
PHP Version:
5.2
Tags:
Complexity:
Sprint Focus:

Description

When creating a custom workspace you can define the mount points to this workspace, however in practice it is more practical to assign users to the workspace and to use the default DB and Filemount permissions.

The uploaded patch allows the fileadmin to list the users file mounts.

(issue imported from #M13763)


Files

patch-usersfilemountsinworkspace.patch (1.2 KB) patch-usersfilemountsinworkspace.patch Administrator Admin, 2010-03-07 16:48
13763_v2.patch (1.69 KB) 13763_v2.patch Administrator Admin, 2010-04-11 23:16

Related issues

Is duplicate of TYPO3 Core - Feature #16554: Workspace DB / filemounts should narrow down the users' mountsClosedBenni Mack2006-09-12

Actions
#1

Updated by Darren Clark about 12 years ago

Note, this issue is related to:
http://bugs.typo3.org/view.php?id=4203

This extends the patch to allow for a workspace setup to allow options such as a custom file mount point or to use the default user file mount point permissions.

#2

Updated by Darren Clark about 12 years ago

Updated patch for TYPO3_4-3-3 and included permissions for admin's to get filemounts in draft workspace attached patch 13763_v2.patch

#3

Updated by Benni Mack over 11 years ago

Hey Darren,

this should be fixed with #16554 and solved in TYPO3 4.5 beta2. Can you confirm this?

#4

Updated by Tolleiv Nietsch about 11 years ago

No feeback for quite some time - assuming that this is already solved

Also available in: Atom PDF