Project

General

Profile

Actions

Bug #22295

closed

textStyle doesn't work

Added by Stefan Froemken almost 14 years ago. Updated about 9 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-03-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I just test some stdWrap-Properties and stubled over textStyle which generates font-Tags. I know...font-Tags are deprecated, but it isn't marked as deprecated and it is documented in TsRef.

My little test-TS:
10 = TEXT
10.value = Ich werde in ein font-Tag gewrapped
10.textStyle.face.field = 1

In frontend I saw only my text. There is no font-Tag wrapped around.

In code I found something like this:

function textStyle(...) {
...
$face = $this->data[$conf['face.']['field']];

What's that?!?! $this->data?!?!

After changing this to:

$face = $conf['face.']['field']

it works like expected.
(issue imported from #M13857)


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Task #49247: Deprecate TypoScript functions "textStyle" and "tableStyle"Closed2013-06-19

Actions
Actions #1

Updated by Stefan Froemken almost 14 years ago

There was somebody asking if this function is deprecated 2 years ago.

0008931

Actions #2

Updated by Alexander Opitz almost 11 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

Actions #3

Updated by Alexander Opitz over 10 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Actions #4

Updated by Stefan Froemken over 10 years ago

I don't know if it is a problem. Maybe it is more a problem regarding an missing documentation.

Sure. Documentation told us to add a fieldname for $this->data, but it does not make sense to type in "header" or "title" as fieldname, because its content will never match some of the configured values in function textStyles which are numeric.

So maybe it is better to type in fieldnames which are numeric like header_layout. Now you have the possibility to set the size for a value with help of this field. But there are some more predefined values like "face" and "color", but there are no more selectboxes in "pages" or "tt_content" which could match.

It would be nice if you (documentation team) adds a little excample for this feature.

Stefan

Actions #5

Updated by Stefan Neufeind over 10 years ago

  • Status changed from Closed to New
Actions #6

Updated by Chris topher about 9 years ago

  • Status changed from New to Rejected

#49247 finally deprecated this feature. textStyle will be removed in CMS 8.

Actions

Also available in: Atom PDF