Bug #22643

Symmetric biderectional records, does not work with type=group

Added by Jan-Erik Revsbech over 9 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2010-05-13
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I have configures a relation from the pages table to itself using an irre and the following configuration

"config" => Array (
"type"=>"inline",
"foreign_table"=>"tx_ksrelatedpages_pages_relations",
"foreign_field"=>"page",
"foreign_label"=>"related",
"foreign_sortby"=>"related_sorting",
"symmetric_field" => "related",
"symmetric_label"=>"page",
"symmetric_sortby"=>"page_sorting"
)

This works fine if the relationstable (tx_ksrelatedpages_pages_relations) is has the page and related fields defined as type="select", but does not work for type="group"

The problem is identified to the t3lib_loadDBGroup::isOnSymmetricSide methods which makes a check to see if the value from the relations page points to the record currently being edited bu using a simple == operator.

But for type=group, the field is not stored as an integer, but stored as pages_43|Title of my page, and thus the method returns false always.

The attached patch fixes this by making a check to see if the field is an integer, and if not, tries to parse it correctly

The problem appears on all versions of TYPO3 since IRRE was introduces, including 4.3.3
(issue imported from #M14378)

patch_isOnSymSide.patch View (1012 Bytes) Administrator Admin, 2010-05-13 02:51


Related issues

Related to TYPO3 Core - Bug #43242: The "foreign_selector" in IRRE fields does not work with foreign group field New 2012-11-23

History

#1 Updated by Oliver Hader almost 7 years ago

  • Category set to 978
  • Target version deleted (0)

#2 Updated by Mathias Schreiber almost 5 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Mathias Schreiber
  • Is Regression set to No

@Olly are the two linked tickets duplicates?
If so, could you close one of them down? :)

#3 Updated by Alexander Opitz over 4 years ago

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (6.2.13)?

#4 Updated by Alexander Opitz about 4 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Mathias Schreiber)

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF