Project

General

Profile

Actions

Bug #22900

closed

Span tags with multiple classes being removed

Added by Adam Casto over 13 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-06-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When a span with more than one class is present within a paragraph, it is being removed. I have verified it with a fresh install of 4.3.3. Here is what I have found so far:

Span within a paragraph with a single class works fine. Classes are properly listed in allowedClasses. All work individually.

Span within another blocklevel element, such as H1, with multiple classes work fine.

Is happening in the transformation from RTE -> DB. Manually adding classes via the database presents fine in both FE and RTE. Subsequently saving from the RTE will remove the classes.

Setting rmTagIfNoAttrib to '0' results in the span being left intact but with no class(es). Meaning span is being stripped because it is being left empty due to a problem handling the classes and not a problem with the tag in particular.

Problem presumably in t3lib/class.t3lib_parsehtml_proc.php

(issue imported from #M14748)


Files

typo3core_bugfix_14748_trunk.patch (1.81 KB) typo3core_bugfix_14748_trunk.patch Administrator Admin, 2010-06-16 06:07

Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #24186: HTMLparser - fixAttrib.['class'].list does not assign first element, when attribute value not in listClosed2010-11-23

Actions
Has duplicate TYPO3 Core - Bug #21485: Multiple assigned classes in Text Style get lost in HTML cleaner.ClosedStanislas Rolland2009-11-06

Actions
Actions #1

Updated by Stanislas Rolland over 13 years ago

Please try attached patch (applies to t3lib/class.t3lib_parsehtml.php).

Actions #2

Updated by Adam Casto over 13 years ago

Seems to be working with the patch. Thanks!

Actions #3

Updated by Stanislas Rolland over 13 years ago

The patch is now on the core list. Please give your +1.

Actions #4

Updated by Stanislas Rolland over 13 years ago

Thanks. I saw the vote in the list. Not sure why it is not linked to the initial post, but that's ok.

Actions #5

Updated by Stanislas Rolland over 13 years ago

Committed to SVN TYPO3core trunk (revision 7945) and branch TYPO3_4-3 (revision 7946).

Actions #6

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF