Bug #22981

Template Analyzer: Line numbers barely readable

Added by Sebastian Michaelsen about 11 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-06-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The line numbers in the Template Analyzer have a very low contrast (white on light-grey) and are barely readable.

I suggest setting the font color to dark-grey (#585858).

See screenshots attached

I don't know in which stylesheet to correct this, because they are merged - sorry.
(issue imported from #M14847)


Files

before.png (3.44 KB) before.png Administrator Admin, 2010-06-24 11:27
after.png (3.35 KB) after.png Administrator Admin, 2010-06-24 11:28
bug_14847.diff (420 Bytes) bug_14847.diff Administrator Admin, 2010-06-25 10:36

Related issues

Has duplicate TYPO3 Core - Bug #22950: Template Analyzer: Line Numbers are very hard to readClosedChris topher2010-06-21

Actions
#1

Updated by Chris topher about 11 years ago

The definitions you mean are:

pre.ts-hl .ts-linenum { background-color: #EEEEEE; }

[inherited from td.bgColor2]
.bgColor2 { color: #FFFFFF; }

PS: You can disable compression of BE-stylesheets in the Install Tool I think.

#2

Updated by Andy Grunwald about 11 years ago

The File is located in "typo3/sysext/t3skin/stylesheets/visual/element_typoscript.css"

I`ve created a patch.
The color of the linenumbers is the same color for the line numbers in TYPO3 4.3.3

I`ve created a RFC on mailling list.

#3

Updated by Steffen Kamper about 11 years ago

committed to svn
4_4 rev 8056
trunk rev 8057

#4

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF