Bug #23081

TYPO3 login expiration Dialog appears again and agian

Added by Frank Naegler over 11 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-07-03
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If your IP change while you are logged in into the backend, a dialog appears:

TYPO3 login expiration notice
Your TYPO3 login is about to expire. Please confirm that you want to stay logged in.

If you click on "stay logged in", the message box disappear and coming back to front immediately. You have to complete login again to stop the dialog.

(issue imported from #M14979)


Related issues

Has duplicate TYPO3 Core - Bug #22713: Logout form / "Relogin" does not work when IP address changesClosed2010-05-25

Actions
#1

Updated by Stephan Großberndt over 11 years ago

Same problem here after returning from standby while logged in- although i am not sure if my ip changed.

#2

Updated by Julien G. over 11 years ago

I just setup Typo3 4.4 on Windows with XAMPP, on 127.0.0.1. I tried to login with the default admin admin/password. The login expiration dialog is always returned. I have delete all entries in table "be_sessions" and set, in localconf :
$TYPO3_CONF_VARS['BE']['enabledBeUserIPLock'] = false;

Login expiration dialog is always displayed...

-- edit --

Login expiration dialog is always displayed if default .htaccess is enabled.

#3

Updated by Ulrich Fischer over 11 years ago

I can confirm the reported problem. Some typo3 installations since the ajax login was established.

#4

Updated by Jogo Hartman over 11 years ago

I had the same since version 4.3.1.
Unfortunately it continues with 4.4.
The Problem arises in Firefox, but not in an older version of Netscape.

#5

Updated by Charles Coleman almost 11 years ago

Still is happening in 4.4.4 for me as well.

#6

Updated by Charles Coleman almost 11 years ago

Not sure it was solved, but here's a lot of discussion on the topic...
http://old.nabble.com/Solving-existing-session-problems---sole-technical-approach-td21712197.html

#7

Updated by Steffen Gebert almost 11 years ago

I'm pretty sure that it's not possible to relogin, if the IP has changed.

#8

Updated by Charles Coleman almost 11 years ago

Here's my scenario...

  • Our web development company website http://www.rapidfyre.net is running TYPO3 in the root directory (/).
  • I created a subdirectory (/clientfolder) for developing a client's website and installed another instance of TYPO3 there.
  • The client TYPO3 site is the one having issues with repeated TYPO3 expiration notices after login.
  • Once the client site is complete we will move it to a new location out of our company directory.
#9

Updated by Rafal Likus almost 11 years ago

We have 3 working sites with at least 3 copies of them for tests. Build with 4.4.2. and PHP 5.3.
Problem can be seen on all of them but not for all BE users, no difference if it is user with Admin option or without.
But the biggest problem is that most of these login expirations is on our Public Relations Team workstations. But sometimest it happens on IT staff workstations to. In Internet Explorer 8, Firefox 3.6.
We cannot help them, we do not know what to say or what to do.
We cannot trace it or reproduce in reasonable way.
In 4.1 problem with logouts in IE8 workaroud with Firefox helped, this time not.

Could you help?

#10

Updated by Alexander Opitz over 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

I'd the same problem with 4.3 and 4.4 installations but I can't remember that I had this with 4.5 installations.

#11

Updated by Franz Holzinger over 8 years ago

Close this issue.

#12

Updated by Alexander Opitz over 8 years ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF