Bug #23175

Validation warnings with sprites

Added by Georg Ringer about 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Could have
Category:
-
Target version:
-
Start date:
2010-07-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Switching to sprites leads to quite a few new validation warnings.

Simple reason:
protected static function buildSpriteHtmlIconTag(array $tagAttributes, $innerHtml = ' ', $tagName = 'span') {}

Default should be   but in the previous call of getSpriteIcon() $innerHtml is set to "":
$innerHtml = (isset($options['html']) ? $options['html'] : '');

Therefore an additional check should be made.

(issue imported from #M15110)


Files

15110-validation-sprites.patch (695 Bytes) 15110-validation-sprites.patch Administrator Admin, 2010-07-14 07:02
rfc15110_v2.diff (3.04 KB) rfc15110_v2.diff Administrator Admin, 2010-07-25 18:34

Related issues

Related to TYPO3 Core - Bug #23606: phpunit: Testsuite: t3lib_iconWorksTest fails some tests due to newly included   between the opening and closing span tagClosedErnesto Baschny2010-09-24

Actions
#1

Updated by Steffen Ritter about 11 years ago

will have a look at it

#2

Updated by Ernesto Baschny almost 11 years ago

Commited v3 (from Stefan Galinksi) to trunk (rev 8749, will be in 4.5alpha2).

#3

Updated by Susanne Moog over 10 years ago

  • Target version deleted (4.5.0)

Also available in: Atom PDF