Bug #23222

CONTENT TS object fails to show translations of pages DB table

Added by Max Mishyn over 9 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-07-18
Due date:
% Done:

100%

TYPO3 Version:
4.4
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since upgrade to 4.4.0 CONTENT TypoScript object started to ignore translations of pages table. It smply shows default language vesrion (content of pages table instead of pages_language_overlay). It works correctly in 4.3.x.

(issue imported from #M15166)

15166.diff View (1.09 KB) Administrator Admin, 2010-07-21 01:35


Related issues

Related to TYPO3 Core - Bug #19275: TypoScript objects CONTENT and RECORDS do not respect localization of table pages Closed 2008-09-02
Related to TYPO3 Core - Bug #17450: No language overlay with TS select on table pages Closed 2007-07-07

History

#1 Updated by Max Mishyn over 9 years ago

Looks like it was my mistake. This functionality (language overlay support for pages table in CONTENT) was added by me in 4.3.3 by patching class.tslib_content.php file.
However here I'm attaching patch to add this functionality in 4.4.x

#2 Updated by Chris topher over 9 years ago

Hi Max,

thanks for your patch!

Do you know that you should now send your patch to Core List? It will then be integrated in future releases of TYPO3.
See here http://typo3.org/teams/core/core-mailinglist-rules/

#4 Updated by Max Mishyn over 9 years ago

What is the current status of this issue? Will it be merged into TYPO3 core?

#5 Updated by Joh. Feustel over 8 years ago

fixed in #17450

#6 Updated by Chris topher over 8 years ago

  • Status changed from Needs Feedback to Resolved
  • Target version deleted (0)
  • % Done changed from 0 to 100

Thanks for the note, Johannes!

Resolved in #17450.

#7 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF