Bug #19275

TypoScript objects CONTENT and RECORDS do not respect localization of table pages

Added by Oliver Hader about 11 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2008-09-02
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Imagine someone wants to display the localized title of a page in FE by the RECORDS object in TypoScript - example:

temp.pageTitle = RECORDS
temp.pageTitle {
source = pages_123
tables = pages
conf.pages < lib.whatever
}

In tslib_cObj there's a call to $GLOBALS['TSFE']->sys_page->getRecordOverlay() which won't work for pages, since pages have an own table for localization stuff - thus getPageOverlay() would be correct for the table 'pages' in the RECORDS and CONTENT TS-object...

Further reasons:
  • pages don't have [ctrl][languageField]
  • missing the check and handling for [ctrl][transForeignTable]

(issue imported from #M9275)

0009275.patch View (5.43 KB) Administrator Admin, 2008-09-02 22:08

0009275_v2.patch View (5.53 KB) Administrator Admin, 2008-09-03 09:36


Related issues

Related to TYPO3 Core - Bug #23222: CONTENT TS object fails to show translations of pages DB table Closed 2010-07-18
Related to TYPO3 Core - Bug #17450: No language overlay with TS select on table pages Closed 2007-07-07
Related to TYPO3 Core - Bug #42279: RECORDS content object does not fetch translations for pages Closed 2012-10-22

History

#1 Updated by Martin Keck almost 10 years ago

I'm not quite sure about it, but I think the patch has a small bug, too.

After patching class.t3lib_page.php the localized output from a RECORDS object worked fine, but the default language output (in my case German) didn't work anymore.

The reason for that behaviour seems to be the check for sys_language_overlay mode in lines 376 ff of the patch. As I use "hideNonTranslated" the $row was completeley reseted, even if the default language was used.

Uncommenting line 377 "unset($row);" did solve the problem for me, but that's actually just a fast hack. Anyone a better solution?

Thx and greets,
Martin

#2 Updated by Chris topher almost 8 years ago

  • Target version changed from 4.6.0 to 4.6.1

#3 Updated by Chris topher almost 8 years ago

  • Target version changed from 4.6.1 to 4.6.2

#4 Updated by Xavier Perseguers over 7 years ago

  • Category deleted (Communication)
  • Assignee deleted (Oliver Hader)
  • Target version deleted (4.6.2)

#5 Updated by Christian Kuhn over 6 years ago

  • Status changed from Accepted to Resolved

solved with #42279

#6 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF