Bug #23503

In TCA Palletes section keyword "--linebreak--" does not work

Added by Florian Sauer over 11 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2010-09-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Inserting the reserved word "--linebreak--" as a "field" in the fieldlist of a palette has no effect in the rendered form of the backend

Suggestion:
In class t3lib_TCEforms - function printPalette($palArr)

change

$out = '<fieldset class="t3-form-palette-fieldset">';
for ($i = 0; $i <= $row; $i++) {
$out .= implode($iRow[$i]);
}
$out .= '&lt;/fieldset&gt;';

to
$out = '';
for ($i = 0; $i <= $row; $i++) {
$out .= '<fieldset class="t3-form-palette-fieldset">';
$out .= implode($iRow[$i]);
$out .= '</fieldset>';
}

This worked for me, as all fields of a palette left and right of "--linebreak" will be enclosed in their own <fieldset>
(issue imported from #M15640)


Related issues

Is duplicate of TYPO3 Core - Bug #23192: Linebreaks does not work anymore BE if using '--linebreak--' in palettesClosedSusanne Moog2010-07-15

Actions
#1

Updated by Andreas Kiessling over 11 years ago

That was fixed 2 days after release of 4.4.2:
http://bugs.typo3.org/view.php?id=15131

#2

Updated by Chris topher over 11 years ago

Resolved as duplicate of #23192.

Indeed, the fix will be part of TYPO3 4.4.3.

#3

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF