Bug #23580

Icon for hidden field doesn't work with IRRE

Added by Guido S. about 10 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2010-09-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since TYPO3 4.4 we cannot deactivate IRRE elements over the standard icon. If we click on the icon we get following error message:

path is undefined
[Break on this error] var backSlash = path.lastIndexOf('\\');

Problem exist in typo3temp/compressor/jsfunc.inline....js

(issue imported from #M15764)


Files

bug_15764.diff (1 KB) bug_15764.diff Administrator Admin, 2010-10-15 11:22

Related issues

Related to TYPO3 Core - Bug #24588: Irre: possible to hide/unhide recordsClosed2011-01-15

Actions
Has duplicate TYPO3 Core - Bug #23818: "Hidden"-Funcanality brocken: JS-Error "formObj[0] is undefined"Closed2010-10-21

Actions
#1

Updated by Guido S. about 10 years ago

Problem is in t3lib/jsfunc.inline.js in function enableDisableRecord (line 674)

He is try to change an image, but the new concept works only with css classes. It must change the css class in the choosen span.

#2

Updated by sweiler no-lastname-given about 10 years ago

example work around (t3lib/jsfunc.inline.js) for complaining editors.

#3

Updated by Andreas Kiessling about 10 years ago

The patch will only work, if the element is expanded.
Since the irre element is loaded on demand, there is a good chance, that clicking on the icon just does nothing.
If i have to expand the record, than i can just use the checkbox there.

Workaround for me:
'appearance' => array(
'enabledControls' => array(
'hide' => FALSE,
),
),

What would probably work: insert an input type hidden as a placeholder to receive the hide/show action.
When the element is loaded, that placeholder could be removed and the "regular behaviour" can be executed.

#4

Updated by Felix Nagel about 9 years ago

  • Target version changed from 0 to 4.5.6

This error persists even in TYPO3 4.5.5.

#5

Updated by Chris topher about 9 years ago

  • Target version changed from 4.5.6 to 4.5.8
#6

Updated by Ernesto Baschny almost 9 years ago

  • Target version changed from 4.5.8 to 4.5.12
#7

Updated by Andreas Wolf over 8 years ago

  • Status changed from New to Resolved

This seems to be fixed in 4.7 and 4.5.

#8

Updated by Riccardo De Contardi about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF