Bug #23812

Wrong search result description for a search word with german umlauts as the first letter

Added by Karl Schlicker almost 12 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-10-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In search words with a German umlaut, as a the first letter the search description has as a result only the last 55 characters of the whole content.

In search words with german umlaut within the search word the description is fine.
It seem as 'preg_split' in the function 'markupSWpartsOfString#' is wrong.

For examples try http://www.autostadt.de/de/suche.html
-with search word 'Öffnungszeiten'
Result:
... Bereichen ausschließlich im Außenareal gestattet.

-with search word 'Mobilität'
Result:
Curriculum Mobilität Fächerübergreifende Mobilitätsbildung Die..
with marked search word.

indexed_search 2.12.0
typo3 4.4.2
php 5.2.14

(issue imported from #M16092)

#1

Updated by Karl Schlicker almost 12 years ago

The same problem on
TYPO3 4.4.3
PHP 5.3.3

#2

Updated by Alexander Opitz over 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • TYPO3 Version set to 4.4
  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (4.5 or 6.1)?

#3

Updated by Karl Schlicker over 8 years ago

I've check version 4.5 now and the problem seems to be fixed.
Thanks.

#4

Updated by Wouter Wolters over 8 years ago

  • Status changed from Needs Feedback to Closed

Thanks for reporting back!

Wouter

Also available in: Atom PDF