Bug #24658

New window instead of new tab when viewing a page from the new page tree

Added by Simon Schaufelberger over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2011-01-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Opening the kontextmenu in the new page tree and selecting the "show" item opens the page in a new window in Firefox. This is ugly since I want a new tab.

In the 3rd frame on the right if i do the same in the docheader of the page, the page is still opening in a new tab as expected.

can this behavior in the page tree be changed please?

(issue imported from #M17136)


Related issues

Is duplicate of TYPO3 Core - Bug #24916: "Show Page" in contextmenu results in new browser windowClosedStefan Galinski2011-02-01

Actions
#1

Updated by Steffen Gebert over 10 years ago

Is there really a way to influence this? Never heard of it.

Simon, maybe you can do some research, whether such a possiblity exists in JS. Maybe ExtJS really makes use of it (and it could be disabled).

#2

Updated by Stefan Galinski over 10 years ago

Currently there is a simple window.open call used and I already tried to fix this. Would be great if someone knows a solution to fix this behaviour as I really dislike it too.

#3

Updated by Steffen Gebert over 10 years ago

Closed in favor of #24916, which has a patch.

Also available in: Atom PDF