Bug #24916

"Show Page" in contextmenu results in new browser window

Added by Christian Nölle about 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
Start date:
2011-02-01
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The link "show page" in the right-click menu of the pagetree is resulting in a new browser window beeing opened up. The "show page" button aside the other buttons in a page detail view is opening up a new tab in the browser.

User could find that inconsistent, two behaviours for the same thing.

Futhermore the pop-up blocker of the browser will prevent that windows from opening. The new tab will mostly work without adding the BE domain to a whitelist.
(issue imported from #M17431)

17431.diff View (532 Bytes) Administrator Admin, 2011-02-03 16:45


Related issues

Related to TYPO3 Core - Bug #24946: "Show" doesn't work in Chrome in new page treee Closed 2011-02-04
Duplicated by TYPO3 Core - Bug #24658: New window instead of new tab when viewing a page from the new page tree Closed 2011-01-19

History

#1 Updated by Sven Juergens about 9 years ago

hi Christian,

i had the same "problem", can you test the attached patch ? "Show Page" should now open again in a tab, not a new window.

After adding patch you must clean your browser cache.

#2 Updated by Christian Nölle about 9 years ago

I will check that out later on.

#3 Updated by Christian Nölle about 9 years ago

Looks good. Is working for me.

#4 Updated by Simon Schaufelberger about 9 years ago

I was digging a bit deeper into this issue and found out that the problem is this function:
function openUrlInWindow(url,windowName) { //
regularWindow = window.open(
url,
windowName,
"status=1,menubar=1,resizable=1,location=1,directories=0,scrollbars=1,toolbar=1");
regularWindow.focus();
return false;
}

in typo3/js/backend.js

As long as there are no third parameters in window.open, everything works well but in this case all typical browsers open another window.

The second thing is that the target window name is not the same in pagetree as in the main content window.

right now we have: "typo3ContextMenuView" but in the main window we have "newTYPO3frontendWindow". This results into 2 independent windows/tabs.

The possibilities: remove the parameters from the function above and rename typo3ContextMenuView to newTYPO3frontendWindow or use the patch and change the window names there.

#5 Updated by Stefan Galinski about 9 years ago

Committed in:
rev 10633 (trunk)
rev 10634 (4.5)

Also available in: Atom PDF