Bug #24735

tceform language-dropdown doesn't show flags

Added by Tolleiv Nietsch about 9 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-01-23
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

There used to be flags below the language dropdown within tt_content forms - but atm. there's just a t3-icon-empty...

(issue imported from #M17225)

language-dropdown.PNG View (1.33 KB) Administrator Admin, 2011-01-23 10:53

0017225_page_languages_overlay.patch View (686 Bytes) Administrator Admin, 2011-01-25 09:08


Related issues

Related to TYPO3 Core - Feature #23519: TYPO3 Backend should display flags for translations as sprite icons Closed 2010-09-08
Duplicated by TYPO3 Core - Bug #25798: Missing flags when editing a content element in different language Closed 2011-04-06

History

#1 Updated by Tolleiv Nietsch about 9 years ago

false alert - it actually never showed the flags - closing it for now to lower the stress of the release-team ;)

#2 Updated by Georg Ringer about 9 years ago

are you sure? I don't have an install right now but aren't there empty icons displayed under the select field? can you let this report open and I check tomorrow again,thx

#3 Updated by Tolleiv Nietsch about 9 years ago

well there is an empty icon below the box (that why I reportet it) but actually there have never been language icons in any TYPO3 version (back to 4.2) - would still be great to have them ;)

#4 Updated by Georg Ringer about 9 years ago

i checked code and there should be flags as I have, e.g. in tt_content under the language selection something like this for every language:
------------
<td><a href="#" onclick="document.editform['data[tt_content][NEW4d3d301ab7b27][sys_language_uid]'].selectedIndex=4; document.editform['data[tt_content][NEW4d3d301ab7b27][sys_language_uid]'].className=document.editform['data[tt_content][NEW4d3d301ab7b27][sys_language_uid]'].options4.className; TBE_EDITOR.fieldChanged('tt_content','NEW4d3d301ab7b27','sys_language_uid','data[tt_content][NEW4d3d301ab7b27][sys_language_uid]');this.blur();return false;"><span alt="Turkish" title="Turkish" class="t3-icon t3-icon-empty t3-icon-empty-empty t3-icon-empty"> </span></a></td>
-------

so there should be a flag

#5 Updated by Ernesto Baschny about 9 years ago

You assign the flag to the sys_language record and then you see the flags if you are translating tt_content (or other records) beneath the records.

Backwards compatibility issue is the in previous versions of TYPO3, the sys_language "flag" was a .gif file (e.g. "tr.gif"), and its now only the flags code (e.g. "tr") (see #23519).

Which is why there is an Upgrade Wizard to migrate sys_language to the new style.

Doesn't it work?

#6 Updated by Georg Ringer about 9 years ago

ah, now used the upgrade wizard but still doesn't work

#7 Updated by Tolleiv Nietsch about 9 years ago

well, the attached patch resolves it for pages_language_overlay, but the attached "solution" can't be used for tt_content (or tt_news) because it doesn't provide the "all" language option...

during the test I also found #24788

#8 Updated by Susanne Moog over 8 years ago

  • Status changed from Needs Feedback to Accepted
  • Target version deleted (0)

#9 Updated by Susanne Moog over 8 years ago

  • Complexity set to medium

#10 Updated by Alexander Opitz over 5 years ago

  • Status changed from Accepted to Needs Feedback
  • Is Regression set to No

Hi,

was this issue fixed or does it still exists?

#11 Updated by Alexander Opitz about 5 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF