Bug #24810

CSH popup windows for FlexForm fields do not show field label

Added by Jeff Segars almost 9 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Could have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-01-25
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When using CSH for FlexForms, the popup window does not show the field label in the header like it does for normal fields. Instead, a path such as tt_content.pi_flexform.myext_pi1.list: myField is shown.

(issue imported from #M17310)

History

#1 Updated by Francois Suter almost 9 years ago

Jeff, I'm not entirely sure what you mean. I don't see the full path.

What I see is the field's name rather than the field's label. Is that just what you meant? I know this issue and I actually made a note about when submitting the original patch.

The issue is the following: before the field label was passed along with other arguments in a base64-encoded blob. This seemed very dirty to me. The new solution is pretty clean, but does not retrieve the label automatically. The reason for this is that in order to get the reference to the label, you need to read the FlexForm's XML structure and parse it in some way (probably using a straight XPath query) to get the label reference (which can then be interpreted using lang::sL()). My reasoning was that this was too much overhead. Indeed the other way of having a proper label is to define an "alttile" in the CSH file. Of course this may feel like double work to extension author. The full solution (described above) is not very complicated to implement. I just wonder if it's worth the overhead.

What's your opinion?

#2 Updated by Alexander Opitz almost 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (6.1.7)?

#3 Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this ticket.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF